HighFix available
pspp — security advisory
There is a reachable assertion abort in the function dict_rename_var() in data/dictionary.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
- Products
- pspp
- Affected versions
- Not specified
- Fixed versions
- 1.0.1-1
- CVEs
- CVE-2017-12960
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:06 UTC · Revision 1
Source evidence
There is a reachable assertion abort in the function dict_rename_var() in data/dictionary.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
osv:DEBIAN-CVE-2017-12960
pspp
Fixed versions: 1.0.1-1
pspp
Fixed versions: 1.0.1-1
pspp
Fixed versions: 1.0.1-1
Complete source record
{
"id": "1917164c4a6c6906c38501b0e9934446a72652a262e460f3a7264d16cafec63b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2017-12960",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2017-12960",
"summary": "There is a reachable assertion abort in the function dict_rename_var() in data/dictionary.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.",
"evidence": "osv:DEBIAN-CVE-2017-12960",
"products": [
{
"name": {
"value": "pspp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.0.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "pspp",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.0.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "pspp",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.0.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2017-12960",
"aliases": [
"DEBIAN-CVE-2017-12960"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.1-1"
}
]
}
],
"package": {
"name": "pspp",
"purl": "pkg:deb/debian/pspp?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2017-12960.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.1-1"
}
]
}
],
"package": {
"name": "pspp",
"purl": "pkg:deb/debian/pspp?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2017-12960.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.1-1"
}
]
}
],
"package": {
"name": "pspp",
"purl": "pkg:deb/debian/pspp?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2017-12960.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
],
"modified": "2026-10-15T06:00:04.773249784Z",
"provider": "osv",
"upstream": [
"CVE-2017-12960"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2017-12960"
]
},
"related_cves": [
{
"value": "CVE-2017-12960",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 321529,
"published_at": "2017-08-18T21:29:00.383+00:00"
}