Skip to content
Heist/ feed
Back to feed
High

Secret encryption vulnerable to brute-force attacks

Type: advisorySources: OSV

Authenticator is a browser extension that generates two-step verification codes. In versions 7.0.0 and below, encryption keys for user data were stored encrypted at-rest using only AES-256 and the EVP_BytesToKey KDF. Therefore, attackers with a copy of a user's data are able to brute-force the user's encryption key. Users on version 8.0.0 and above are automatically migrated away from the weak encoding on first login. Users should destroy encrypted backups made with versions prior to 8.0.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-45394
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 08:40 UTC · Revision 1

Source evidence

Secret encryption vulnerable to brute-force attacks

core-osv · Original source

Published 3 Sept 2024, 20:15 UTC

Authenticator is a browser extension that generates two-step verification codes. In versions 7.0.0 and below, encryption keys for user data were stored encrypted at-rest using only AES-256 and the EVP_BytesToKey KDF. Therefore, attackers with a copy of a user's data are able to brute-force the user's encryption key. Users on version 8.0.0 and above are automatically migrated away from the weak encoding on first login. Users should destroy encrypted backups made with versions prior to 8.0.0.

osv:CVE-2024-45394
Complete source record
{
  "id": "5774b29cf493fed5f836bf2cad175ee6059a4e742ba0b01197a5b2743f1c09c3",
  "url": "https://osv.dev/vulnerability/CVE-2024-45394",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Secret encryption vulnerable to brute-force attacks",
    "summary": "Authenticator is a browser extension that generates two-step verification codes. In versions 7.0.0 and below, encryption keys for user data were stored encrypted at-rest using only AES-256 and the EVP_BytesToKey KDF. Therefore, attackers with a copy of a user's data are able to brute-force the user's encryption key. Users on version 8.0.0 and above are automatically migrated away from the weak encoding on first login. Users should destroy encrypted backups made with versions prior to 8.0.0.",
    "evidence": "osv:CVE-2024-45394",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2024-45394",
      "aliases": [
        "CVE-2024-45394",
        "GHSA-gv8m-vgp8-q2xr"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/authenticator-extension/authenticator",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2cf9b0ff3014bf5db88a3e834e7a2c2c54c96410"
                },
                {
                  "fixed": "17aa2068553db3c3aac081c9ffe393536f33b28b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:authenticator:authenticator:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "8.0.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "17aa2068553db3c3aac081c9ffe393536f33b28b"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v6.3.1",
            "v6.3.0",
            "v6.2.1",
            "v6.2.0",
            "v6.1.0",
            "v6.0.1",
            "v6.0.0",
            "v5.3.2",
            "v5.3.1",
            "v5.3.0",
            "v5.2.2",
            "v5.2.1",
            "v5.2.0",
            "v5.1.1",
            "v5.1.0",
            "v5.0.10",
            "v5.0.9",
            "v5.0.8",
            "v5.0.7",
            "v5.0.6",
            "v5.0.5",
            "v5.0.4"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-45394.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:50.345849841Z",
      "provider": "osv",
      "references": [
        "https://github.com/Authenticator-Extension/Authenticator/security/advisories/GHSA-gv8m-vgp8-q2xr",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/45xxx/CVE-2024-45394.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-45394",
        "https://github.com/Authenticator-Extension/Authenticator/commit/17aa2068553db3c3aac081c9ffe393536f33b28b"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-261",
          "CWE-327"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/45xxx/CVE-2024-45394.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-45394",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 518776,
  "published_at": "2024-09-03T20:15:42.769+00:00"
}