Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-21389

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-21389
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:32 UTC · Revision 1

Source evidence

CVE-2021-21389

core-osv · Original source

Published 26 Mar 2021, 21:15 UTC

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

osv:CVE-2021-21389
Complete source record
{
  "id": "7dd9390775f78d1276e54d1fe31315fb156c92aed3cea02313d739d7e6ecbf71",
  "url": "https://osv.dev/vulnerability/CVE-2021-21389",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-21389",
    "summary": "BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.",
    "evidence": "osv:CVE-2021-21389",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2021-21389",
      "aliases": [
        "CVE-2021-21389",
        "GHSA-m6j4-8r7p-wpp3"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/buddypress/buddypress",
              "type": "GIT",
              "events": [
                {
                  "introduced": "9a29774bb86d2befe8c29ff8d75c4b55fbbcb71f"
                },
                {
                  "fixed": "de194818216fd5a84a67a8430c354ae6803fe280"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "5.0.0"
                      },
                      {
                        "fixed": "7.2.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21389.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:28.484032412Z",
      "provider": "osv",
      "references": [
        "https://buddypress.org/2021/03/buddypress-7-2-1-security-release/",
        "https://codex.buddypress.org/releases/version-7-2-1/",
        "https://github.com/buddypress/BuddyPress/security/advisories/GHSA-m6j4-8r7p-wpp3"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-21389",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385416,
  "published_at": "2021-03-26T21:15:13.52+00:00"
}