snowflake — security advisory
Pion DTLS is a Go implementation of Datagram Transport Layer Security. Prior to version 2.1.5, a DTLS Client could provide a Certificate that it doesn't posses the private key for and Pion DTLS wouldn't reject it. This issue affects users that are using Client certificates only. The connection itself is still secure. The Certificate provided by clients can't be trusted when using a Pion DTLS server prior to version 2.1.5. Users should upgrade to version 2.1.5 to receive a patch. There are currently no known workarounds.
- Products
- snowflake
- Affected versions
- Not specified
- Fixed versions
- 2.2.0-1
- CVEs
- CVE-2022-29222
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:00 UTC · Revision 1
Source evidence
Pion DTLS is a Go implementation of Datagram Transport Layer Security. Prior to version 2.1.5, a DTLS Client could provide a Certificate that it doesn't posses the private key for and Pion DTLS wouldn't reject it. This issue affects users that are using Client certificates only. The connection itself is still secure. The Certificate provided by clients can't be trusted when using a Pion DTLS server prior to version 2.1.5. Users should upgrade to version 2.1.5 to receive a patch. There are currently no known workarounds.
osv:DEBIAN-CVE-2022-29222
snowflake
Fixed versions: 2.2.0-1
snowflake
Fixed versions: 2.2.0-1
snowflake
Fixed versions: 2.2.0-1
Complete source record
{
"id": "7804d096ad2f5dc876e14a4122b71fa31baef76eb57d6c1d608430fd415796c0",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-29222",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-29222",
"summary": "Pion DTLS is a Go implementation of Datagram Transport Layer Security. Prior to version 2.1.5, a DTLS Client could provide a Certificate that it doesn't posses the private key for and Pion DTLS wouldn't reject it. This issue affects users that are using Client certificates only. The connection itself is still secure. The Certificate provided by clients can't be trusted when using a Pion DTLS server prior to version 2.1.5. Users should upgrade to version 2.1.5 to receive a patch. There are currently no known workarounds.",
"evidence": "osv:DEBIAN-CVE-2022-29222",
"products": [
{
"name": {
"value": "snowflake",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.2.0-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "snowflake",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.2.0-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "snowflake",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.2.0-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-29222",
"aliases": [
"DEBIAN-CVE-2022-29222"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.0-1"
}
]
}
],
"package": {
"name": "snowflake",
"purl": "pkg:deb/debian/snowflake?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-29222.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.0-1"
}
]
}
],
"package": {
"name": "snowflake",
"purl": "pkg:deb/debian/snowflake?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-29222.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.0-1"
}
]
}
],
"package": {
"name": "snowflake",
"purl": "pkg:deb/debian/snowflake?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-29222.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:43.232404813Z",
"provider": "osv",
"upstream": [
"CVE-2022-29222"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-29222"
]
},
"related_cves": [
{
"value": "CVE-2022-29222",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324048,
"published_at": "2022-05-21T00:15:12.047+00:00"
}