squid — security advisory
Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Affected versions of squid are subject to a a Use-After-Free bug which can lead to a Denial of Service attack via collapsed forwarding. All versions of Squid from 3.5 up to and including 5.9 configured with "collapsed_forwarding on" are vulnerable. Configurations with "collapsed_forwarding off" or without a "collapsed_forwarding" directive are not vulnerable. This bug is fixed by Squid version 6.0.1. Users are advised to upgrade. Users unable to upgrade should remove all collapsed_forwarding lines from their squid.conf.
- Products
- squid
- Affected versions
- 5.7-2, 5.7-2+deb12u1, 5.7-2+deb12u2, 5.7-2+deb12u3, 5.7-2+deb12u4, 5.7-2+deb12u5, 5.7-2+deb12u6, 6.1-1, 6.1-2, 6.10-1, 6.12-1, 6.13-1, 6.13-2, 6.3-1, 6.5-1, 6.6-1, 6.8-1, 6.9-1, 7.1-1, 7.2-1, 7.2-2, 7.4-1, 7.5-1, 7.6-1, 7.6-2, 7.7-1
- Fixed versions
- 6.1-1
- CVEs
- CVE-2023-49288
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 16:11 UTC · Revision 1
Source evidence
Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Affected versions of squid are subject to a a Use-After-Free bug which can lead to a Denial of Service attack via collapsed forwarding. All versions of Squid from 3.5 up to and including 5.9 configured with "collapsed_forwarding on" are vulnerable. Configurations with "collapsed_forwarding off" or without a "collapsed_forwarding" directive are not vulnerable. This bug is fixed by Squid version 6.0.1. Users are advised to upgrade. Users unable to upgrade should remove all collapsed_forwarding lines from their squid.conf.
osv:DEBIAN-CVE-2023-49288
squid
Fixed versions: Not specified
squid
Fixed versions: 6.1-1
squid
Fixed versions: 6.1-1
Complete source record
{
"id": "850ac145bcdfa19cfee9381714d0ffb909744f19f28e847aa74d073d578f591a",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-49288",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-49288",
"summary": "Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Affected versions of squid are subject to a a Use-After-Free bug which can lead to a Denial of Service attack via collapsed forwarding. All versions of Squid from 3.5 up to and including 5.9 configured with \"collapsed_forwarding on\" are vulnerable. Configurations with \"collapsed_forwarding off\" or without a \"collapsed_forwarding\" directive are not vulnerable. This bug is fixed by Squid version 6.0.1. Users are advised to upgrade. Users unable to upgrade should remove all collapsed_forwarding lines from their squid.conf.",
"evidence": "osv:DEBIAN-CVE-2023-49288",
"products": [
{
"name": {
"value": "squid",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.7-2",
"evidence": "/affected/0/versions"
},
{
"value": "5.7-2+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "5.7-2+deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "5.7-2+deb12u3",
"evidence": "/affected/0/versions"
},
{
"value": "5.7-2+deb12u4",
"evidence": "/affected/0/versions"
},
{
"value": "5.7-2+deb12u5",
"evidence": "/affected/0/versions"
},
{
"value": "5.7-2+deb12u6",
"evidence": "/affected/0/versions"
},
{
"value": "6.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.1-2",
"evidence": "/affected/0/versions"
},
{
"value": "6.10-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.12-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.13-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.13-2",
"evidence": "/affected/0/versions"
},
{
"value": "6.3-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.5-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.6-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.8-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.9-1",
"evidence": "/affected/0/versions"
},
{
"value": "7.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "7.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "7.2-2",
"evidence": "/affected/0/versions"
},
{
"value": "7.4-1",
"evidence": "/affected/0/versions"
},
{
"value": "7.5-1",
"evidence": "/affected/0/versions"
},
{
"value": "7.6-1",
"evidence": "/affected/0/versions"
},
{
"value": "7.6-2",
"evidence": "/affected/0/versions"
},
{
"value": "7.7-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "squid",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "squid",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-49288",
"aliases": [
"DEBIAN-CVE-2023-49288"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "squid",
"purl": "pkg:deb/debian/squid?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"5.7-2",
"5.7-2+deb12u1",
"5.7-2+deb12u2",
"5.7-2+deb12u3",
"5.7-2+deb12u4",
"5.7-2+deb12u5",
"5.7-2+deb12u6",
"6.1-1",
"6.1-2",
"6.10-1",
"6.12-1",
"6.13-1",
"6.13-2",
"6.3-1",
"6.5-1",
"6.6-1",
"6.8-1",
"6.9-1",
"7.1-1",
"7.2-1",
"7.2-2",
"7.4-1",
"7.5-1",
"7.6-1",
"7.6-2",
"7.7-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-49288.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.1-1"
}
]
}
],
"package": {
"name": "squid",
"purl": "pkg:deb/debian/squid?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-49288.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.1-1"
}
]
}
],
"package": {
"name": "squid",
"purl": "pkg:deb/debian/squid?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-49288.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:50.232823761Z",
"provider": "osv",
"upstream": [
"CVE-2023-49288"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-49288"
]
},
"related_cves": [
{
"value": "CVE-2023-49288",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456956,
"published_at": "2023-12-04T23:15:27.477+00:00"
}