Skip to content
Heist/ feed
Back to feed
MediumFix available

qemu — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2021-20221

An out-of-bounds heap buffer access issue was found in the ARM Generic Interrupt Controller emulator of QEMU up to and including qemu 4.2.0on aarch64 platform. The issue occurs because while writing an interrupt ID to the controller memory area, it is not masked to be 4 bits wide. It may lead to the said issue while updating controller state fields and their subsequent processing. A privileged guest user may use this flaw to crash the QEMU process on the host resulting in DoS scenario.

Products
qemu
Affected versions
Not specified
Fixed versions
1:5.2+dfsg-4
CVEs
CVE-2021-20221
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 01:39 UTC · Revision 1

Source evidence

DEBIAN-CVE-2021-20221

core-osv · Original source

Published 13 May 2021, 16:15 UTC

An out-of-bounds heap buffer access issue was found in the ARM Generic Interrupt Controller emulator of QEMU up to and including qemu 4.2.0on aarch64 platform. The issue occurs because while writing an interrupt ID to the controller memory area, it is not masked to be 4 bits wide. It may lead to the said issue while updating controller state fields and their subsequent processing. A privileged guest user may use this flaw to crash the QEMU process on the host resulting in DoS scenario.

osv:DEBIAN-CVE-2021-20221

qemu

Fixed versions: 1:5.2+dfsg-4

qemu

Fixed versions: 1:5.2+dfsg-4

qemu

Fixed versions: 1:5.2+dfsg-4

Complete source record
{
  "id": "ce16190ad5375959e2b95b23503653719da386b234418a65a6ba2c86d90e13d5",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-20221",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2021-20221",
    "summary": "An out-of-bounds heap buffer access issue was found in the ARM Generic Interrupt Controller emulator of QEMU up to and including qemu 4.2.0on aarch64 platform. The issue occurs because while writing an interrupt ID to the controller memory area, it is not masked to be 4 bits wide. It may lead to the said issue while updating controller state fields and their subsequent processing. A privileged guest user may use this flaw to crash the QEMU process on the host resulting in DoS scenario.",
    "evidence": "osv:DEBIAN-CVE-2021-20221",
    "products": [
      {
        "name": {
          "value": "qemu",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:5.2+dfsg-4",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "qemu",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:5.2+dfsg-4",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "qemu",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:5.2+dfsg-4",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2021-20221",
      "aliases": [
        "DEBIAN-CVE-2021-20221"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:5.2+dfsg-4"
                }
              ]
            }
          ],
          "package": {
            "name": "qemu",
            "purl": "pkg:deb/debian/qemu?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-20221.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:5.2+dfsg-4"
                }
              ]
            }
          ],
          "package": {
            "name": "qemu",
            "purl": "pkg:deb/debian/qemu?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-20221.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:5.2+dfsg-4"
                }
              ]
            }
          ],
          "package": {
            "name": "qemu",
            "purl": "pkg:deb/debian/qemu?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-20221.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:04:48.840602576Z",
      "provider": "osv",
      "upstream": [
        "CVE-2021-20221"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2021-20221"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2021-20221",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 423916,
  "published_at": "2021-05-13T16:15:07.697+00:00"
}