Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2025-57348

The node-cube package (prior to version 5.0.0) contains a vulnerability in its handling of prototype chain initialization, which could allow an attacker to inject properties into the prototype of built-in objects. This issue, categorized under CWE-1321, arises from improper validation of user-supplied input in the package's resource initialization process. Successful exploitation may lead to denial of service or arbitrary code execution in affected environments. The vulnerability affects versions up to and including 5.0.0-beta.19, and no official fix has been released to date.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-57348
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 01:25 UTC · Revision 1

Source evidence

CVE-2025-57348

core-osv · Original source

Published 24 Sept 2025, 00:00 UTC

The node-cube package (prior to version 5.0.0) contains a vulnerability in its handling of prototype chain initialization, which could allow an attacker to inject properties into the prototype of built-in objects. This issue, categorized under CWE-1321, arises from improper validation of user-supplied input in the package's resource initialization process. Successful exploitation may lead to denial of service or arbitrary code execution in affected environments. The vulnerability affects versions up to and including 5.0.0-beta.19, and no official fix has been released to date.

osv:CVE-2025-57348
Complete source record
{
  "id": "285abd091158528b3a34a15f0923c6eaee24db5378bc7063394a886e1bcadebf",
  "url": "https://osv.dev/vulnerability/CVE-2025-57348",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2025-57348",
    "summary": "The node-cube package (prior to version 5.0.0) contains a vulnerability in its handling of prototype chain initialization, which could allow an attacker to inject properties into the prototype of built-in objects. This issue, categorized under CWE-1321, arises from improper validation of user-supplied input in the package's resource initialization process. Successful exploitation may lead to denial of service or arbitrary code execution in affected environments. The vulnerability affects versions up to and including 5.0.0-beta.19, and no official fix has been released to date.",
    "evidence": "osv:CVE-2025-57348",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-57348",
      "aliases": [
        "CVE-2025-57348",
        "GHSA-8v65-5fw5-23wj"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/node-cube/cube",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "ef96598b8e8e73a643c4b18b0179fe444d082eda"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "5.0.0-beta.19"
                      }
                    ],
                    "source": "DESCRIPTION"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v5.0.0-beta.19",
            "v5.0.0-beta.17",
            "v3.1.27",
            "v3.1.25",
            "v3.1.24",
            "v3.1.23",
            "v3.1.21",
            "v3.0.0-beta.14",
            "v3.0.0-beta.10",
            "v3.0.0-beta.9",
            "v3.0.0-beta.8",
            "v3.0.0-beta.7",
            "v3.0.0-beta.6",
            "v3.0.0-beta.4",
            "v3.0.0-beta.2",
            "v2.0.1",
            "v2.0.0",
            "v1.0.7",
            "v1.0.6",
            "v1.0.5",
            "v1.0.4",
            "v1.0.3",
            "v1.0.0",
            "v0.2.7",
            "v0.1.4",
            "v0.1.3",
            "v0.1.1",
            "v0.1.0",
            "v0.0.18",
            "v0.0.17",
            "v0.0.16",
            "v0.0.15",
            "v0.0.10",
            "v0.0.9",
            "v0.0.7",
            "v0.0.6",
            "v0.0.5",
            "v0.0.2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-57348.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:48.869379720Z",
      "provider": "osv",
      "references": [
        "https://github.com/VulnSageAgent/PoCs/tree/main/JavaScript/prototype-pollution/CVE-2025-57348",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/57xxx/CVE-2025-57348.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-57348",
        "https://github.com/node-cube/cube/issues/153"
      ],
      "provider_metadata": {
        "cna_assigner": "mitre",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "5.0.0"
                  }
                ],
                "source": "DESCRIPTION"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/57xxx/CVE-2025-57348.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-57348",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 516962,
  "published_at": "2025-09-24T00:00:00+00:00"
}