UnratedFix available
apache2 — security advisory
The mod_proxy_ajp module in the Apache HTTP Server before 2.2.21, when used with mod_proxy_balancer in certain configurations, allows remote attackers to cause a denial of service (temporary "error state" in the backend server) via a malformed HTTP request.
- Products
- apache2
- Affected versions
- Not specified
- Fixed versions
- 2.2.21-1
- CVEs
- CVE-2011-3348
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 23:25 UTC · Revision 1
Source evidence
The mod_proxy_ajp module in the Apache HTTP Server before 2.2.21, when used with mod_proxy_balancer in certain configurations, allows remote attackers to cause a denial of service (temporary "error state" in the backend server) via a malformed HTTP request.
osv:DEBIAN-CVE-2011-3348
apache2
Fixed versions: 2.2.21-1
apache2
Fixed versions: 2.2.21-1
apache2
Fixed versions: 2.2.21-1
Complete source record
{
"id": "a6365f10149ebd377e7a3831a6eb0020e3b265b6a24481896caa53ff9080eb21",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2011-3348",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2011-3348",
"summary": "The mod_proxy_ajp module in the Apache HTTP Server before 2.2.21, when used with mod_proxy_balancer in certain configurations, allows remote attackers to cause a denial of service (temporary \"error state\" in the backend server) via a malformed HTTP request.",
"evidence": "osv:DEBIAN-CVE-2011-3348",
"products": [
{
"name": {
"value": "apache2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.2.21-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "apache2",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.2.21-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "apache2",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.2.21-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2011-3348",
"aliases": [
"DEBIAN-CVE-2011-3348"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.21-1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-3348.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.21-1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-3348.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.21-1"
}
]
}
],
"package": {
"name": "apache2",
"purl": "pkg:deb/debian/apache2?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-3348.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:43.450369557Z",
"provider": "osv",
"upstream": [
"CVE-2011-3348"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2011-3348"
]
},
"related_cves": [
{
"value": "CVE-2011-3348",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 418562,
"published_at": "2011-09-20T05:55:02.983+00:00"
}