node-undici — security advisory
undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.
- Products
- node-undici
- Affected versions
- 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1, 5.26.3+dfsg1+~cs23.10.12-2, 7.16.0+dfsg+~cs3.2.0-2, 7.18.2+dfsg+~cs3.2.0-1, 7.18.2+dfsg+~cs3.2.0-1build1, 7.24.6+dfsg+~cs3.2.0-3, 7.3.0+dfsg1+~cs24.12.11-2, 8.5.0+dfsg+~cs3.2.0-2, 8.5.0+dfsg+~cs3.2.0-3, 8.9.0+dfsg+~cs3.2.0-1
- Fixed versions
- Not specified
- CVEs
- CVE-2026-84890
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 03:23 UTC · Revision 1
Source evidence
undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.
osv:UBUNTU-CVE-2026-84890
node-undici
Fixed versions: Not specified
node-undici
Fixed versions: Not specified
node-undici
Fixed versions: Not specified
Complete source record
{
"id": "58a902653a1284963849b43eb44f6fc904a6481db3a2309e8fc7b91632c34378",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-84890",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-84890",
"summary": "undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.",
"evidence": "osv:UBUNTU-CVE-2026-84890",
"products": [
{
"name": {
"value": "node-undici",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "5.26.3+dfsg1+~cs23.10.12-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "node-undici",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "7.18.2+dfsg+~cs3.2.0-1build1",
"evidence": "/affected/1/versions"
},
{
"value": "7.24.6+dfsg+~cs3.2.0-3",
"evidence": "/affected/1/versions"
},
{
"value": "8.5.0+dfsg+~cs3.2.0-2",
"evidence": "/affected/1/versions"
},
{
"value": "8.5.0+dfsg+~cs3.2.0-3",
"evidence": "/affected/1/versions"
},
{
"value": "8.9.0+dfsg+~cs3.2.0-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "node-undici",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "7.3.0+dfsg1+~cs24.12.11-2",
"evidence": "/affected/2/versions"
},
{
"value": "7.16.0+dfsg+~cs3.2.0-2",
"evidence": "/affected/2/versions"
},
{
"value": "7.18.2+dfsg+~cs3.2.0-1",
"evidence": "/affected/2/versions"
},
{
"value": "7.18.2+dfsg+~cs3.2.0-1build1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2026-84890",
"aliases": [
"UBUNTU-CVE-2026-84890"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-undici",
"purl": "pkg:deb/ubuntu/node-undici?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1",
"5.26.3+dfsg1+~cs23.10.12-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-84890.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-llhttp",
"binary_version": "9.1.3~5.26.3+dfsg1+~cs23.10.12-2"
},
{
"binary_name": "node-undici",
"binary_version": "5.26.3+dfsg1+~cs23.10.12-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-undici",
"purl": "pkg:deb/ubuntu/node-undici?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"7.18.2+dfsg+~cs3.2.0-1build1",
"7.24.6+dfsg+~cs3.2.0-3",
"8.5.0+dfsg+~cs3.2.0-2",
"8.5.0+dfsg+~cs3.2.0-3",
"8.9.0+dfsg+~cs3.2.0-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-84890.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-undici",
"binary_version": "8.9.0+dfsg+~cs3.2.0-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-undici",
"purl": "pkg:deb/ubuntu/node-undici?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"7.3.0+dfsg1+~cs24.12.11-2",
"7.16.0+dfsg+~cs3.2.0-2",
"7.18.2+dfsg+~cs3.2.0-1",
"7.18.2+dfsg+~cs3.2.0-1build1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-84890.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-undici",
"binary_version": "7.18.2+dfsg+~cs3.2.0-1build1"
}
]
}
}
],
"modified": "2026-10-17T13:01:12.989267200Z",
"provider": "osv",
"upstream": [
"CVE-2026-84890"
],
"references": [
"https://ubuntu.com/security/CVE-2026-84890",
"https://www.cve.org/CVERecord?id=CVE-2026-84890",
"https://github.com/nodejs/undici/security/advisories/GHSA-3xpg-4rpp-hhhm"
]
},
"related_cves": [
{
"value": "CVE-2026-84890",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 361269,
"published_at": "2026-09-04T18:18:00+00:00"
}