Skip to content
Heist/ feed
Back to feed
High

Filament's multi-factor authentication (app) recovery codes can be used multiple times

Type: advisorySources: OSV

Filament is a collection of full-stack components for accelerated Laravel development. Versions 4.0.0 through 4.3.0 contain a flaw in the handling of recovery codes for app-based multi-factor authentication, allowing the same recovery code to be reused indefinitely. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled. This issue is fixed in version 4.3.1.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-67507
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 03:53 UTC · Revision 1

Source evidence

Filament's multi-factor authentication (app) recovery codes can be used multiple times

core-osv · Original source

Published 10 Dec 2025, 00:43 UTC

Filament is a collection of full-stack components for accelerated Laravel development. Versions 4.0.0 through 4.3.0 contain a flaw in the handling of recovery codes for app-based multi-factor authentication, allowing the same recovery code to be reused indefinitely. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled. This issue is fixed in version 4.3.1.

osv:CVE-2025-67507
Complete source record
{
  "id": "1eba42dde166e65ee77df3428d088490e2413274a87d2bffe730f192bb007382",
  "url": "https://osv.dev/vulnerability/CVE-2025-67507",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Filament's multi-factor authentication (app) recovery codes can be used multiple times",
    "summary": "Filament is a collection of full-stack components for accelerated Laravel development. Versions 4.0.0 through 4.3.0 contain a flaw in the handling of recovery codes for app-based multi-factor authentication, allowing the same recovery code to be reused indefinitely. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled. This issue is fixed in version 4.3.1.",
    "evidence": "osv:CVE-2025-67507",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-67507",
      "aliases": [
        "CVE-2025-67507",
        "GHSA-pvcv-q3q7-266g"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/filamentphp/filament",
              "type": "GIT",
              "events": [
                {
                  "introduced": "7c842bb196df3d587ce8ae57178af191dce37e0c"
                },
                {
                  "fixed": "87ff60ad9b6e16d4e14ee36a220b8917dd7b0815"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "4.0.0"
                      },
                      {
                        "fixed": "4.3.1"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "87ff60ad9b6e16d4e14ee36a220b8917dd7b0815"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "cpe": "cpe:2.3:a:filamentphp:filament:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "4.0.0"
                      },
                      {
                        "fixed": "4.3.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v4.3.0",
            "v4.2.4",
            "v4.2.3",
            "v4.2.2",
            "v4.2.1",
            "v4.2.0",
            "v4.1.10",
            "v4.1.9",
            "v4.1.8",
            "v4.1.7",
            "v4.1.6",
            "v4.1.5",
            "v4.1.4",
            "v4.1.3",
            "v4.1.2",
            "v4.1.1",
            "v4.1.0",
            "v4.0.20",
            "v4.0.19",
            "v4.0.18",
            "v4.0.17",
            "v4.0.16",
            "v4.0.15",
            "v4.0.14",
            "v4.0.13",
            "v4.0.12",
            "v4.0.11",
            "v4.0.10",
            "v4.0.9",
            "v4.0.8",
            "v4.0.7",
            "v4.0.6",
            "v4.0.5",
            "v4.0.4",
            "v4.0.3",
            "v4.0.2",
            "v4.0.1",
            "v4.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-67507.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:49.648238831Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/67xxx/CVE-2025-67507.json",
        "https://github.com/filamentphp/filament/security/advisories/GHSA-pvcv-q3q7-266g",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-67507",
        "https://github.com/filamentphp/filament/commit/87ff60ad9b6e16d4e14ee36a220b8917dd7b0815"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-287",
          "CWE-288"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/67xxx/CVE-2025-67507.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-67507",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 517914,
  "published_at": "2025-12-10T00:43:06.855+00:00"
}