jupyterlab — security advisory
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.
- Products
- jupyterlab
- Affected versions
- 4.0.11+ds1+~cs11.25.27-5, 4.0.11+ds1+~cs11.25.27-6, 4.0.11+ds1+~cs11.25.27-7, 4.0.11+ds1+~cs11.25.27-8, 4.0.11+ds1+~cs11.25.27-9, 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3, 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- Fixed versions
- Not specified
- CVEs
- CVE-2026-42266
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 02:12 UTC · Revision 1
Source evidence
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.
osv:UBUNTU-CVE-2026-42266
jupyterlab
Fixed versions: Not specified
jupyterlab
Fixed versions: Not specified
jupyterlab
Fixed versions: Not specified
Complete source record
{
"id": "aa17fbf1012af9aafa4832683a757cb32ebd674bade4f422a617e8ac4e85e7c2",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-42266",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-42266",
"summary": "JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.",
"evidence": "osv:UBUNTU-CVE-2026-42266",
"products": [
{
"name": {
"value": "jupyterlab",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.0.11+ds1+~cs11.25.27-5",
"evidence": "/affected/0/versions"
},
{
"value": "4.0.11+ds1+~cs11.25.27-6",
"evidence": "/affected/0/versions"
},
{
"value": "4.0.11+ds1+~cs11.25.27-7",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "jupyterlab",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.0.11+ds1+~cs11.25.27-9",
"evidence": "/affected/1/versions"
},
{
"value": "4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3",
"evidence": "/affected/1/versions"
},
{
"value": "4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "jupyterlab",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "4.0.11+ds1+~cs11.25.27-7",
"evidence": "/affected/2/versions"
},
{
"value": "4.0.11+ds1+~cs11.25.27-8",
"evidence": "/affected/2/versions"
},
{
"value": "4.0.11+ds1+~cs11.25.27-9",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2026-42266",
"aliases": [
"UBUNTU-CVE-2026-42266"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "jupyterlab",
"purl": "pkg:deb/ubuntu/jupyterlab?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"4.0.11+ds1+~cs11.25.27-5",
"4.0.11+ds1+~cs11.25.27-6",
"4.0.11+ds1+~cs11.25.27-7"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-42266.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "jupyterlab",
"binary_version": "4.0.11+ds1+~cs11.25.27-7"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "jupyterlab",
"purl": "pkg:deb/ubuntu/jupyterlab?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"4.0.11+ds1+~cs11.25.27-9",
"4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3",
"4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-42266.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "jupyterlab",
"binary_version": "4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "jupyterlab",
"purl": "pkg:deb/ubuntu/jupyterlab?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"4.0.11+ds1+~cs11.25.27-7",
"4.0.11+ds1+~cs11.25.27-8",
"4.0.11+ds1+~cs11.25.27-9"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-42266.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "jupyterlab",
"binary_version": "4.0.11+ds1+~cs11.25.27-9"
}
]
}
}
],
"modified": "2026-10-17T12:58:16.780126190Z",
"provider": "osv",
"upstream": [
"CVE-2026-42266"
],
"references": [
"https://ubuntu.com/security/CVE-2026-42266",
"https://www.cve.org/CVERecord?id=CVE-2026-42266",
"https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-37w4-hwhx-4rc4"
]
},
"related_cves": [
{
"value": "CVE-2026-42266",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 358504,
"published_at": "2026-05-13T16:16:00+00:00"
}