linux — security advisory
There exists a use-after-free vulnerability in the Linux kernel through io_uring and the IORING_OP_SPLICE operation. If IORING_OP_SPLICE is missing the IO_WQ_WORK_FILES flag, which signals that the operation won't use current->nsproxy, so its reference counter is not increased. This assumption is not always true as calling io_splice on specific files will call the get_uts function which will use current->nsproxy leading to invalidly decreasing its reference counter later causing the use-after-free vulnerability. We recommend upgrading to version 5.10.160 or above
- Products
- linux
- Affected versions
- Not specified
- Fixed versions
- 5.14.6-1
- CVEs
- CVE-2022-4696
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:03 UTC · Revision 1
Source evidence
There exists a use-after-free vulnerability in the Linux kernel through io_uring and the IORING_OP_SPLICE operation. If IORING_OP_SPLICE is missing the IO_WQ_WORK_FILES flag, which signals that the operation won't use current->nsproxy, so its reference counter is not increased. This assumption is not always true as calling io_splice on specific files will call the get_uts function which will use current->nsproxy leading to invalidly decreasing its reference counter later causing the use-after-free vulnerability. We recommend upgrading to version 5.10.160 or above
osv:DEBIAN-CVE-2022-4696
linux
Fixed versions: 5.14.6-1
linux
Fixed versions: 5.14.6-1
linux
Fixed versions: 5.14.6-1
Complete source record
{
"id": "4727ecdcfcef6fe30b2413b8515f94ad05b16c3bb14f8461346e304fefe79660",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-4696",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-4696",
"summary": "There exists a use-after-free vulnerability in the Linux kernel through io_uring and the IORING_OP_SPLICE operation. If IORING_OP_SPLICE is missing the IO_WQ_WORK_FILES flag, which signals that the operation won't use current->nsproxy, so its reference counter is not increased. This assumption is not always true as calling io_splice on specific files will call the get_uts function which will use current->nsproxy leading to invalidly decreasing its reference counter later causing the use-after-free vulnerability. We recommend upgrading to version 5.10.160 or above",
"evidence": "osv:DEBIAN-CVE-2022-4696",
"products": [
{
"name": {
"value": "linux",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.14.6-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "linux",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.14.6-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "linux",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.14.6-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-4696",
"aliases": [
"DEBIAN-CVE-2022-4696"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.14.6-1"
}
]
}
],
"package": {
"name": "linux",
"purl": "pkg:deb/debian/linux?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-4696.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.14.6-1"
}
]
}
],
"package": {
"name": "linux",
"purl": "pkg:deb/debian/linux?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-4696.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.14.6-1"
}
]
}
],
"package": {
"name": "linux",
"purl": "pkg:deb/debian/linux?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-4696.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:46.473623636Z",
"provider": "osv",
"upstream": [
"CVE-2022-4696"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-4696"
]
},
"related_cves": [
{
"value": "CVE-2022-4696",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324199,
"published_at": "2023-01-11T13:15:09.307+00:00"
}