High
Security advisory
Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-21311
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:14 UTC · Revision 1
Source evidence
Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.
osv:CVE-2021-21311
Complete source record
{
"id": "4fbee0040ebe49c6717be7ef813245918523e2fb42403121d6366efe52501956",
"url": "https://osv.dev/vulnerability/CVE-2021-21311",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-21311",
"summary": "Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.",
"evidence": "osv:CVE-2021-21311",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-21311",
"aliases": [
"CVE-2021-21311",
"GHSA-x5r2-hj5c-8jx6"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/vrana/adminer",
"type": "GIT",
"events": [
{
"introduced": "184273750aa4b255e54b30296f580ebca89a2d39"
},
{
"fixed": "93c7fb248ca008e3247eb3a43812e1096e7b262c"
},
{
"fixed": "ccd2374b0b12bd547417bf0dacdf153826c83351"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:adminer:adminer:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.7.9"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "ccd2374b0b12bd547417bf0dacdf153826c83351"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v4.7.8",
"v4.7.7",
"v4.7.5",
"v4.7.4",
"v4.7.3",
"v4.7.2",
"v4.7.1",
"v4.7.0",
"v4.6.3",
"v4.6.2",
"v4.6.1",
"v4.6.0",
"v4.5.0",
"v4.4.0",
"v4.3.1",
"v4.3.0",
"v4.2.5",
"v4.2.4",
"v4.2.3",
"v4.2.2",
"v4.2.1",
"v4.2.0",
"v4.1.0",
"v4.0.3",
"v4.0.2",
"v4.0.1",
"v4.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21311.json"
}
}
],
"modified": "2026-10-20T10:53:33.505547597Z",
"provider": "osv",
"references": [
"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-21311",
"https://lists.debian.org/debian-lts-announce/2021/03/msg00002.html",
"https://packagist.org/packages/vrana/adminer",
"https://github.com/vrana/adminer/commit/ccd2374b0b12bd547417bf0dacdf153826c83351",
"https://github.com/vrana/adminer/security/advisories/GHSA-x5r2-hj5c-8jx6",
"https://github.com/vrana/adminer/files/5957311/Adminer.SSRF.pdf"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2021-21311",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 384418,
"published_at": "2021-02-11T21:15:13.82+00:00"
}