Skip to content
Heist/ feed
Back to feed
CriticalFix available

Apache Solr affected by Apache Log4J CVE-2021-44228

Type: advisorySources: Apache Solr security

Apache Solr versions using the bundled Log4J library are affected by CVE-2021-44228. Upgrade to Solr 8.11.1 or greater, or use one of the listed mitigations. The announcement says Solr is not vulnerable to CVE-2021-45046 or CVE-2021-45105.

Products
Apache Solr
Affected versions
7.4.0 to 7.7.3, 8.0.0 to 8.11.0
Fixed versions
8.11.1
CVEs
CVE-2021-44228, CVE-2021-45046, CVE-2021-45105
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 21:39 UTC · Revision 1

Source evidence

Apache Solr affected by Apache Log4J CVE-2021-44228

official-apache-solr-security · Original source

Published 10 Dec 2021, 00:00 UTC

Apache Solr versions using the bundled Log4J library are affected by CVE-2021-44228. Upgrade to Solr 8.11.1 or greater, or use one of the listed mitigations. The announcement says Solr is not vulnerable to CVE-2021-45046 or CVE-2021-45105.

Apache Solr releases prior to 8.11.1 were using a bundled version of the Apache Log4J library vulnerable to RCE.

Apache Solr

Fixed versions: 8.11.1

Complete source record
{
  "id": "9305b1812a36bc162ec1b6beba5213c02b661841e3738b4d435cdd08baceca51",
  "url": "https://solr.apache.org/apache-solr-affected-by-apache-log4j-cve-2021-44228.html",
  "method": "llm",
  "payload": {
    "kind": "advisory",
    "title": "Apache Solr affected by Apache Log4J CVE-2021-44228",
    "summary": "Apache Solr versions using the bundled Log4J library are affected by CVE-2021-44228. Upgrade to Solr 8.11.1 or greater, or use one of the listed mitigations. The announcement says Solr is not vulnerable to CVE-2021-45046 or CVE-2021-45105.",
    "evidence": "Apache Solr releases prior to 8.11.1 were using a bundled version of the Apache Log4J library vulnerable to RCE.",
    "products": [
      {
        "name": {
          "value": "Apache Solr",
          "evidence": "Apache Solr affected by Apache Log4J CVE-2021-44228"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "8.11.1",
            "evidence": "Upgrade to Solr 8.11.1 or greater (when available), which will include an updated version (>= 2.16.0) of the Log4J dependency."
          }
        ],
        "affected_versions": [
          {
            "value": "7.4.0 to 7.7.3",
            "evidence": "Versions Affected: 7.4.0 to 7.7.3, 8.0.0 to 8.11.0"
          },
          {
            "value": "8.0.0 to 8.11.0",
            "evidence": "Versions Affected: 7.4.0 to 7.7.3, 8.0.0 to 8.11.0"
          }
        ]
      }
    ],
    "severity": "critical",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2021-44228",
        "evidence": "Apache Solr affected by Apache Log4J CVE-2021-44228"
      },
      {
        "value": "CVE-2021-45046",
        "evidence": "Solr is not vulnerable to the followup CVE-2021-45046 and CVE-2021-45105."
      },
      {
        "value": "CVE-2021-45105",
        "evidence": "Solr is not vulnerable to the followup CVE-2021-45046 and CVE-2021-45105."
      }
    ],
    "security_relevant": true,
    "severity_evidence": "Severity: Critical"
  },
  "source_id": "official-apache-solr-security",
  "document_id": 22985,
  "published_at": "2021-12-10T00:00:00+00:00"
}