High
Security advisory
WordPress before 5.2.4 does not properly consider type confusion during validation of the referer in the admin pages, possibly leading to CSRF.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-17675
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 08:36 UTC · Revision 1
Source evidence
WordPress before 5.2.4 does not properly consider type confusion during validation of the referer in the admin pages, possibly leading to CSRF.
osv:CVE-2019-17675
Complete source record
{
"id": "84ed0a57cb83563ef2768c22a166a827601920ed7c15f99b3d39cdb291f17ea8",
"url": "https://osv.dev/vulnerability/CVE-2019-17675",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-17675",
"summary": "WordPress before 5.2.4 does not properly consider type confusion during validation of the referer in the admin pages, possibly leading to CSRF.",
"evidence": "osv:CVE-2019-17675",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2019-17675",
"aliases": [
"CVE-2019-17675"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9b84a21d66d7da3edec388f49234c1c41daed9ad"
},
{
"fixed": "b183fd1cca0b44a92f0264823dd9f22d2fd8b8d0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.2.4"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "b183fd1cca0b44a92f0264823dd9f22d2fd8b8d0"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-17675.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress-develop",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "c5f94fc512bdea317e3e433b22a2f11ef959e515"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.2.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-17675.json"
}
}
],
"modified": "2026-10-24T10:47:42.228156431Z",
"provider": "osv",
"references": [
"https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html",
"https://lists.debian.org/debian-lts-announce/2019/11/msg00000.html",
"https://seclists.org/bugtraq/2020/Jan/8",
"https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/",
"https://wpvulndb.com/vulnerabilities/9913",
"https://www.debian.org/security/2020/dsa-4599",
"https://www.debian.org/security/2020/dsa-4677",
"https://core.trac.wordpress.org/changeset/46477",
"https://github.com/WordPress/WordPress/commit/b183fd1cca0b44a92f0264823dd9f22d2fd8b8d0"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
},
{
"introduced": "10.0"
},
{
"last_affected": "10.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2019-17675",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 441480,
"published_at": "2019-10-17T13:15:11.22+00:00"
}