Skip to content
Heist/ feed
Back to feed
Unrated

Apache Traffic Server: Configuration option to block the PUSH method in ATS didn't work

Type: advisorySources: OSV

Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-30631
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 04:10 UTC · Revision 1

Source evidence

Apache Traffic Server: Configuration option to block the PUSH method in ATS didn't work

core-osv · Original source

Published 14 Jun 2023, 07:44 UTC

Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions

osv:CVE-2023-30631
Complete source record
{
  "id": "aed015800e2a0ca7b4afdf3aa9d708eb23748cd46eeb57bf4b804c05b7de6ebd",
  "url": "https://osv.dev/vulnerability/CVE-2023-30631",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Traffic Server: Configuration option to block the PUSH method in ATS didn't work",
    "summary": "Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions",
    "evidence": "osv:CVE-2023-30631",
    "products": [],
    "severity": "unknown",
    "structured": {
      "id": "CVE-2023-30631",
      "aliases": [
        "CVE-2023-30631"
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/trafficserver",
              "type": "GIT",
              "events": [
                {
                  "introduced": "b310e3566f58dd04ec2b15b111ec86ea70e20019"
                },
                {
                  "fixed": "005a6ce785df717b2bf565dc07b66b4f918c024c"
                },
                {
                  "introduced": "b14030656330ed623cd1f9efe2f4f9abd9d16e29"
                },
                {
                  "fixed": "c0402b7f021092a8fef885d78ec2608a8bd3f375"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "8.0.0"
                      },
                      {
                        "fixed": "8.1.7"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "9.0.0"
                      },
                      {
                        "fixed": "9.2.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "8.1.6-rc0",
            "8.1.6",
            "8.1.5-rc0",
            "8.1.5",
            "8.1.4-rc0",
            "8.1.4",
            "8.1.3-rc1",
            "8.1.3",
            "8.1.3-rc0",
            "8.1.2-rc0",
            "8.1.1-rc0",
            "8.1.1",
            "8.1.0-rc0",
            "8.1.0",
            "8.0.6-rc1",
            "8.0.6",
            "8.0.6-rc0",
            "8.0.5",
            "8.0.4",
            "8.0.4-rc0",
            "8.0.3-rc0",
            "8.0.3",
            "8.0.2-rc0",
            "8.0.2",
            "8.0.1-rc0",
            "8.0.1",
            "8.0.0-rc4",
            "8.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-30631.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:49.413040149Z",
      "provider": "osv",
      "references": [
        "https://lists.debian.org/debian-lts-announce/2023/06/msg00037.html",
        "https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6GDCBNFDDW6ULW7CACJCPENI7BVDHM5O/",
        "https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FGWXNAEEVRUZ5JG4EJAIIFC3CI7LFETV/",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/30xxx/CVE-2023-30631.json",
        "https://lists.apache.org/thread/tns2b4khyyncgs5v5p9y35pobg9z2bvs",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-30631",
        "https://www.debian.org/security/2023/dsa-5435"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-20"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "8.0.0"
                  },
                  {
                    "last_affected": "9.2.0"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/30xxx/CVE-2023-30631.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-30631",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 518021,
  "published_at": "2023-06-14T07:44:55.149+00:00"
}