Skip to content
Heist/ feed
Back to feed
High

Multer vulnerable to Denial of Service from maliciously crafted requests

Type: advisorySources: OSV

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-47944
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 07:17 UTC · Revision 1

Source evidence

Multer vulnerable to Denial of Service from maliciously crafted requests

core-osv · Original source

Published 19 May 2025, 19:20 UTC

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.

osv:CVE-2025-47944
Complete source record
{
  "id": "a591fbafea961064b5e00d768db92753dcead50c79e4703b0ebea4c9b57e9edf",
  "url": "https://osv.dev/vulnerability/CVE-2025-47944",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Multer vulnerable to Denial of Service from maliciously crafted requests",
    "summary": "Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.",
    "evidence": "osv:CVE-2025-47944",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-47944",
      "aliases": [
        "CVE-2025-47944",
        "GHSA-4pg4-qvpc-4q3h"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/expressjs/multer",
              "type": "GIT",
              "events": [
                {
                  "introduced": "59c7ef3bc5080de3203f0a0d5243a18bcf11175e"
                },
                {
                  "fixed": "2c8505f207d923dd8de13a9f93a4563e59933665"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "1.4.4-lts.1"
                      },
                      {
                        "fixed": "2.0.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "2c8505f207d923dd8de13a9f93a4563e59933665"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.4.5-lts.2",
            "v1.4.5-lts.1",
            "v1.4.4-lts.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-47944.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:26.988090394Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/47xxx/CVE-2025-47944.json",
        "https://github.com/expressjs/multer/security/advisories/GHSA-4pg4-qvpc-4q3h",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-47944",
        "https://github.com/expressjs/multer/issues/1176",
        "https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-248"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/47xxx/CVE-2025-47944.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-47944",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 493325,
  "published_at": "2025-05-19T19:20:45.401+00:00"
}