Discourse vulnerable to multisite DoS by spamming backups
Discourse is an open-source discussion platform. Prior to version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches, a user logged as an administrator can request backups multiple times, which will eat up all the connections to the DB. If this is done on a site using multisite, then it can affect the whole cluster. The vulnerability is patched in version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-28107
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 05:51 UTC · Revision 1
Source evidence
Discourse vulnerable to multisite DoS by spamming backups
core-osv · Original sourcePublished 17 Mar 2023, 16:23 UTC
Discourse is an open-source discussion platform. Prior to version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches, a user logged as an administrator can request backups multiple times, which will eat up all the connections to the DB. If this is done on a site using multisite, then it can affect the whole cluster. The vulnerability is patched in version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
osv:CVE-2023-28107
Complete source record
{
"id": "b3f868285a92e14e65dd0bfeb53d16c759b1f175069fe94146d99429ccbdaea7",
"url": "https://osv.dev/vulnerability/CVE-2023-28107",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Discourse vulnerable to multisite DoS by spamming backups",
"summary": "Discourse is an open-source discussion platform. Prior to version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches, a user logged as an administrator can request backups multiple times, which will eat up all the connections to the DB. If this is done on a site using multisite, then it can affect the whole cluster. The vulnerability is patched in version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.",
"evidence": "osv:CVE-2023-28107",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-28107",
"aliases": [
"BIT-discourse-2023-28107",
"CVE-2023-28107",
"GHSA-cp7c-fm4c-6xxx"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/discourse/discourse",
"type": "GIT",
"events": [
{
"introduced": "e54f52a756c032d7f35c0907b03a7dc9f2ea65e5"
},
{
"fixed": "0bd64788d2b4680c04fbef76314a24884d65fed9"
},
{
"fixed": "78a3efa7104eed6dd3ed7a06a71e2705337d9e61"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "stable < 3.0.2"
},
{
"last_affected": "stable < 3.0.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "beta < 3.1.0.beta3"
},
{
"last_affected": "beta < 3.1.0.beta3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "tests-passed < 3.1.0.beta3"
},
{
"last_affected": "tests-passed < 3.1.0.beta3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "0bd64788d2b4680c04fbef76314a24884d65fed9"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "78a3efa7104eed6dd3ed7a06a71e2705337d9e61"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"3.1.0-beta1",
"3.1.0-beta2",
"beta < 3.1.0.beta3",
"stable < 3.0.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-28107.json"
}
}
],
"modified": "2026-10-28T02:30:43.281246149Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/28xxx/CVE-2023-28107.json",
"https://github.com/discourse/discourse/security/advisories/GHSA-cp7c-fm4c-6xxx",
"https://nvd.nist.gov/vuln/detail/CVE-2023-28107",
"https://github.com/discourse/discourse/commit/0bd64788d2b4680c04fbef76314a24884d65fed9",
"https://github.com/discourse/discourse/commit/78a3efa7104eed6dd3ed7a06a71e2705337d9e61",
"https://github.com/discourse/discourse/pull/20700",
"https://github.com/discourse/discourse/pull/20701"
],
"provider_metadata": {
"cwe_ids": [
"CWE-770"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/28xxx/CVE-2023-28107.json"
}
},
"related_cves": [
{
"value": "CVE-2023-28107",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 510828,
"published_at": "2023-03-17T16:23:31.324+00:00"
}