Popup Maker – Boost Sales, Conversions, Optins, Subscribers with the Ultimate WP Popups Builder <= 1.20.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
The Popup Maker – Boost Sales, Conversions, Optins, Subscribers with the Ultimate WP Popups Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘post_title’ parameter in all versions up to, and including, 1.20.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-10583
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 21:20 UTC · Revision 1
Source evidence
Popup Maker – Boost Sales, Conversions, Optins, Subscribers with the Ultimate WP Popups Builder <= 1.20.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
core-osv · Original sourcePublished 12 Dec 2024, 06:46 UTC
The Popup Maker – Boost Sales, Conversions, Optins, Subscribers with the Ultimate WP Popups Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘post_title’ parameter in all versions up to, and including, 1.20.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
osv:CVE-2024-10583
Complete source record
{
"id": "fb4ae57433c49750fbe39ffd93aaeb944539b8d713670ee1eb836909c3577977",
"url": "https://osv.dev/vulnerability/CVE-2024-10583",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Popup Maker – Boost Sales, Conversions, Optins, Subscribers with the Ultimate WP Popups Builder <= 1.20.2 - Authenticated (Contributor+) Stored Cross-Site Scripting",
"summary": "The Popup Maker – Boost Sales, Conversions, Optins, Subscribers with the Ultimate WP Popups Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘post_title’ parameter in all versions up to, and including, 1.20.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
"evidence": "osv:CVE-2024-10583",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-10583",
"aliases": [
"CVE-2024-10583"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/popupmaker/popup-maker",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9d4abd62b08353f82fe808f8a9e0d3905e073dac"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:code-atlantic:popup_maker:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.20.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.20.2",
"v1.20.1",
"v1.20.0",
"1.19.2",
"1.19.1",
"1.19.0",
"1.18.5",
"1.18.3",
"v1.18.2",
"1.18.1",
"1.18.0",
"1.17.1",
"1.17.0",
"1.16.14",
"1.16.13",
"1.16.12",
"1.16.11",
"1.16.10",
"v1.16.9",
"1.16.8",
"v1.16.7",
"v1.16.6",
"v1.16.5",
"v1.16.4",
"v1.16.3",
"1.14.0",
"1.13.1",
"1.13.0",
"1.12.0",
"1.11.2",
"1.11.1",
"v1.11.0",
"v1.10.2",
"v1.10.1",
"v1.10.0",
"v1.9.2",
"v1.9.1",
"v1.9.0",
"v1.8.14",
"v1.8.13",
"v1.8.11",
"v1.8.9",
"v1.8.8",
"v1.8.7",
"v1.8.5",
"v1.8.3",
"v1.8.1",
"v1.8.0",
"v1.8.0-beta.1",
"v1.7.30",
"v1.7.29",
"v1.7.28",
"v1.7.27",
"v1.7.26",
"v1.7.22",
"v1.7.21",
"v1.7.19",
"v1.7.17",
"v1.7.15",
"v1.7.14",
"v1.7.12",
"v1.7.9",
"v1.7.7",
"v1.6.6",
"v1.6.5",
"v1.6.4",
"v1.5.8",
"v1.5.7",
"v1.5.6",
"v1.5.5",
"v1.5.4",
"v1.5.3",
"v1.5.2",
"v1.5.1",
"v1.4.21",
"v1.4.20",
"v1.4.19",
"v1.4.18",
"v1.4.17",
"v1.4.16",
"v1.4.15",
"v1.4.14",
"v1.4.13",
"v1.4.11",
"v1.4.9",
"v1.4.8",
"v1.4.7",
"v1.4.6",
"v1.4.5",
"v1.4.2",
"v1.3.7",
"v1.3.6",
"v1.3.5",
"v1.3.4",
"v1.3.3",
"v1.3.2",
"v1.3.1",
"v1.3",
"v1.2.1",
"v1.1.8"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-10583.json"
}
}
],
"modified": "2026-10-28T02:30:51.611609066Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3197898%40popup-maker&new=3197898%40popup-maker&sfp_email=&sfph_mail=",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/5b4dc917-0d59-4163-a613-49afc1dc4d33?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/10xxx/CVE-2024-10583.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-10583"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "1.20.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/10xxx/CVE-2024-10583.json"
}
},
"related_cves": [
{
"value": "CVE-2024-10583",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 520438,
"published_at": "2024-12-12T06:46:33.622+00:00"
}