Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-23568

The package extend2 before 1.0.1 are vulnerable to Prototype Pollution via the extend function due to unsafe recursive merge.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-23568
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:40 UTC · Revision 1

Source evidence

CVE-2021-23568

core-osv · Original source

Published 10 Jan 2022, 14:10 UTC

The package extend2 before 1.0.1 are vulnerable to Prototype Pollution via the extend function due to unsafe recursive merge.

osv:CVE-2021-23568
Complete source record
{
  "id": "c3393195697d09933415b570c112698bda4fe82a4d43ea6d10ae85fb43f9083d",
  "url": "https://osv.dev/vulnerability/CVE-2021-23568",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-23568",
    "summary": "The package extend2 before 1.0.1 are vulnerable to Prototype Pollution via the extend function due to unsafe recursive merge.",
    "evidence": "osv:CVE-2021-23568",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2021-23568",
      "aliases": [
        "CVE-2021-23568",
        "GHSA-gjm5-83cw-p3p2",
        "SNYK-JS-EXTEND2-2320315"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/eggjs/extend2",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "28b347dc661790a6d8d8050c2b59f5586bf3ae63"
                },
                {
                  "fixed": "aa332a59116c8398976434b57ea477c6823054f8"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:eggjs:extend2:*:*:*:*:*:node.js:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.0.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "aa332a59116c8398976434b57ea477c6823054f8"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.0.0",
            "v3.0.0",
            "v2.0.1",
            "v2.0.0",
            "v1.3.0",
            "v1.2.1",
            "v1.2.0",
            "v1.1.3",
            "v1.1.2",
            "v1.1.1",
            "v1.1.0",
            "v1.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-23568.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:32.760980704Z",
      "provider": "osv",
      "references": [
        "https://github.com/eggjs/extend2/blob/master/index.js%23L50-L60",
        "https://github.com/eggjs/extend2/commit/aa332a59116c8398976434b57ea477c6823054f8",
        "https://github.com/eggjs/extend2/pull/2",
        "https://snyk.io/vuln/SNYK-JS-EXTEND2-2320315"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-23568",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385546,
  "published_at": "2022-01-10T14:10:17.043+00:00"
}