Apache Sling Servlets Resolver: Malicious code execution via path traversal
Malicious code execution via path traversal in Apache Software Foundation Apache Sling Servlets Resolver.This issue affects all version of Apache Sling Servlets Resolver before 2.11.0. However, whether a system is vulnerable to this attack depends on the exact configuration of the system. If the system is vulnerable, a user with write access to the repository might be able to trick the Sling Servlet Resolver to load a previously uploaded script. Users are recommended to upgrade to version 2.11.0, which fixes this issue. It is recommended to upgrade, regardless of whether your system configuration currently allows this attack or not.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-23673
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 18:22 UTC · Revision 1
Source evidence
Apache Sling Servlets Resolver: Malicious code execution via path traversal
core-osv · Original sourcePublished 6 Feb 2024, 10:04 UTC
Malicious code execution via path traversal in Apache Software Foundation Apache Sling Servlets Resolver.This issue affects all version of Apache Sling Servlets Resolver before 2.11.0. However, whether a system is vulnerable to this attack depends on the exact configuration of the system. If the system is vulnerable, a user with write access to the repository might be able to trick the Sling Servlet Resolver to load a previously uploaded script. Users are recommended to upgrade to version 2.11.0, which fixes this issue. It is recommended to upgrade, regardless of whether your system configuration currently allows this attack or not.
osv:CVE-2024-23673
Complete source record
{
"id": "a99b4aed11825bc67c861de36d7ccfb7b833abc7ab16b4b6023f87f0e1a37a17",
"url": "https://osv.dev/vulnerability/CVE-2024-23673",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Sling Servlets Resolver: Malicious code execution via path traversal",
"summary": "Malicious code execution via path traversal in Apache Software Foundation Apache Sling Servlets Resolver.This issue affects all version of Apache Sling Servlets Resolver before 2.11.0. However, whether a system is vulnerable to this attack depends on the exact configuration of the system. If the system is vulnerable, a user with write access to the repository might be able to trick the Sling Servlet Resolver to load a previously uploaded script. Users are recommended to upgrade to version 2.11.0, which fixes this issue. It is recommended to upgrade, regardless of whether your system configuration currently allows this attack or not.",
"evidence": "osv:CVE-2024-23673",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-23673",
"aliases": [
"CVE-2024-23673",
"GHSA-h2rq-qhr7-53gm"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/sling-org-apache-sling-servlets-resolver",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "37438b942426a0022add0e7b99b0b84c1e554f70"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:sling_servlets_resolver:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.11.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"org.apache.sling.servlets.resolver-2.10.0",
"org.apache.sling.servlets.resolver-2.9.14",
"org.apache.sling.servlets.resolver-2.9.12",
"org.apache.sling.servlets.resolver-2.9.10",
"org.apache.sling.servlets.resolver-2.9.8",
"org.apache.sling.servlets.resolver-2.9.6",
"org.apache.sling.servlets.resolver-2.9.4",
"org.apache.sling.servlets.resolver-2.9.2",
"org.apache.sling.servlets.resolver-2.9.0",
"org.apache.sling.servlets.resolver-2.8.2",
"org.apache.sling.servlets.resolver-2.8.0",
"org.apache.sling.servlets.resolver-2.7.14",
"org.apache.sling.servlets.resolver-2.7.12",
"org.apache.sling.servlets.resolver-2.7.10",
"org.apache.sling.servlets.resolver-2.7.8",
"org.apache.sling.servlets.resolver-2.7.6",
"org.apache.sling.servlets.resolver-2.7.4",
"org.apache.sling.servlets.resolver-2.7.2",
"org.apache.sling.servlets.resolver-2.7.0",
"org.apache.sling.servlets.resolver-2.6.4",
"org.apache.sling.servlets.resolver-2.6.2",
"org.apache.sling.servlets.resolver-2.6.0",
"org.apache.sling.servlets.resolver-2.5.8",
"org.apache.sling.servlets.resolver-2.5.6",
"org.apache.sling.servlets.resolver-2.5.4",
"org.apache.sling.servlets.resolver-2.5.2",
"org.apache.sling.servlets.resolver-2.4.24",
"org.apache.sling.servlets.resolver-2.4.22",
"org.apache.sling.servlets.resolver-2.4.20",
"org.apache.sling.servlets.resolver-2.4.18",
"org.apache.sling.servlets.resolver-2.4.16"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-23673.json"
}
}
],
"modified": "2026-10-28T02:30:21.845286905Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/23xxx/CVE-2024-23673.json",
"https://lists.apache.org/thread/5zzx8ztwc6tmbwlw80m2pbrp3913l2kl",
"https://nvd.nist.gov/vuln/detail/CVE-2024-23673"
],
"provider_metadata": {
"cwe_ids": [
"CWE-22"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "2.11.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/23xxx/CVE-2024-23673.json"
}
},
"related_cves": [
{
"value": "CVE-2024-23673",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 488290,
"published_at": "2024-02-06T10:04:21.294+00:00"
}