Security advisory
An XSSI (cross-site inclusion) vulnerability in Jupyter Notebook before 5.7.6 allows inclusion of resources on malicious pages when visited by users who are authenticated with a Jupyter server. Access to the content of resources has been demonstrated with Internet Explorer through capturing of error messages, though not reproduced with other browsers. This occurs because Internet Explorer's error messages can include the content of any invalid JavaScript that was encountered.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-9644
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 08:44 UTC · Revision 1
Source evidence
An XSSI (cross-site inclusion) vulnerability in Jupyter Notebook before 5.7.6 allows inclusion of resources on malicious pages when visited by users who are authenticated with a Jupyter server. Access to the content of resources has been demonstrated with Internet Explorer through capturing of error messages, though not reproduced with other browsers. This occurs because Internet Explorer's error messages can include the content of any invalid JavaScript that was encountered.
osv:CVE-2019-9644
Complete source record
{
"id": "1361de0b82280e73ccee38759940d8d822a1b312ee7006f9483ad04825627d2e",
"url": "https://osv.dev/vulnerability/CVE-2019-9644",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-9644",
"summary": "An XSSI (cross-site inclusion) vulnerability in Jupyter Notebook before 5.7.6 allows inclusion of resources on malicious pages when visited by users who are authenticated with a Jupyter server. Access to the content of resources has been demonstrated with Internet Explorer through capturing of error messages, though not reproduced with other browsers. This occurs because Internet Explorer's error messages can include the content of any invalid JavaScript that was encountered.",
"evidence": "osv:CVE-2019-9644",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2019-9644",
"aliases": [
"CVE-2019-9644",
"GHSA-hhx8-cr55-qcxx",
"PYSEC-2019-159",
"PYSEC-2026-2531"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jupyter/notebook",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "05aa4b2cffb55896b53f0a5e50bc9bca405cb29f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.7.6"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"5.7.5",
"5.7.4",
"5.7.3",
"5.7.2",
"5.7.1",
"5.7.0",
"5.6.0",
"5.6.0rc1",
"5.5.0",
"5.5.0rc1",
"5.4.0",
"5.3.1",
"5.3.0",
"5.3.0rc1",
"5.2.0",
"5.2.0rc1",
"5.1.0",
"5.1.0rc3",
"5.1.0rc1",
"5.0.0",
"5.0.0rc2",
"5.0.0-rc.1",
"5.0.0b2",
"5.0.0b1",
"4.1.0",
"4.0.1",
"4.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-9644.json"
}
}
],
"modified": "2026-10-24T10:49:55.730866633Z",
"provider": "osv",
"references": [
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UP5RLEES2JBBNSNLBR65XM6PCD4EMF7D/",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VMDPJBVXOVO6LYGAT46VZNHH6JKSCURO/",
"https://github.com/jupyter/notebook/compare/f3f00df...05aa4b2"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:*"
],
"vendor_product": "jupyter:notebook",
"extracted_events": [
{
"range": [
{
"fixed": "5.7.6"
}
],
"source": "CPE_RANGE"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2019-9644",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 441877,
"published_at": "2019-03-12T09:29:00.297+00:00"
}