Skip to content
Heist/ feed
Back to feed
MediumFix available

wordpress — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2018-20147

In WordPress before 4.9.9 and 5.x before 5.0.1, authors could modify metadata to bypass intended restrictions on deleting files.

Products
wordpress
Affected versions
Not specified
Fixed versions
5.0.1+dfsg1-1
CVEs
CVE-2018-20147
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 00:12 UTC · Revision 1

Source evidence

DEBIAN-CVE-2018-20147

core-osv · Original source

Published 14 Dec 2018, 20:29 UTC

In WordPress before 4.9.9 and 5.x before 5.0.1, authors could modify metadata to bypass intended restrictions on deleting files.

osv:DEBIAN-CVE-2018-20147

wordpress

Fixed versions: 5.0.1+dfsg1-1

wordpress

Fixed versions: 5.0.1+dfsg1-1

wordpress

Fixed versions: 5.0.1+dfsg1-1

Complete source record
{
  "id": "5fa84cac7c76796210718f24421643a8bb404675e243d93628256aad9cb554be",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-20147",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2018-20147",
    "summary": "In WordPress before 4.9.9 and 5.x before 5.0.1, authors could modify metadata to bypass intended restrictions on deleting files.",
    "evidence": "osv:DEBIAN-CVE-2018-20147",
    "products": [
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.0.1+dfsg1-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.0.1+dfsg1-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.0.1+dfsg1-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2018-20147",
      "aliases": [
        "DEBIAN-CVE-2018-20147"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.0.1+dfsg1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-20147.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.0.1+dfsg1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-20147.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.0.1+dfsg1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-20147.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:03:04.668156382Z",
      "provider": "osv",
      "upstream": [
        "CVE-2018-20147"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2018-20147"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2018-20147",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 420328,
  "published_at": "2018-12-14T20:29:00.343+00:00"
}