Skip to content
Heist/ feed
Back to feed
HighFix available

node-handlebars — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2019-20920

Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).

Products
node-handlebars
Affected versions
Not specified
Fixed versions
3:4.5.3-1
CVEs
CVE-2019-20920
Confirmed fixed CVEs
Not specified
Updated in this feed
28 Oct 2026, 11:06 UTC · Revision 1

Source evidence

DEBIAN-CVE-2019-20920

core-osv · Original source

Published 30 Sept 2020, 18:15 UTC

Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).

osv:DEBIAN-CVE-2019-20920

node-handlebars

Fixed versions: 3:4.5.3-1

node-handlebars

Fixed versions: 3:4.5.3-1

node-handlebars

Fixed versions: 3:4.5.3-1

Complete source record
{
  "id": "1322422a7cdb2dc02b9e2d4f193e9e599ebda8790893f511838913b6ba1f0efb",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2019-20920",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2019-20920",
    "summary": "Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).",
    "evidence": "osv:DEBIAN-CVE-2019-20920",
    "products": [
      {
        "name": {
          "value": "node-handlebars",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3:4.5.3-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "node-handlebars",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3:4.5.3-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "node-handlebars",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3:4.5.3-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2019-20920",
      "aliases": [
        "DEBIAN-CVE-2019-20920"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3:4.5.3-1"
                }
              ]
            }
          ],
          "package": {
            "name": "node-handlebars",
            "purl": "pkg:deb/debian/node-handlebars?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2019-20920.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3:4.5.3-1"
                }
              ]
            }
          ],
          "package": {
            "name": "node-handlebars",
            "purl": "pkg:deb/debian/node-handlebars?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2019-20920.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3:4.5.3-1"
                }
              ]
            }
          ],
          "package": {
            "name": "node-handlebars",
            "purl": "pkg:deb/debian/node-handlebars?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2019-20920.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-09T09:47:22.444878156Z",
      "provider": "osv",
      "upstream": [
        "CVE-2019-20920"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2019-20920"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2019-20920",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 111413,
  "published_at": "2020-09-30T18:15:17.927+00:00"
}