Skip to content
Heist/ feed
Back to feed
Medium

Knowage is vulnerable to blind server-side request forgery (SSRF)

Type: advisorySources: OSV

Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, there is a blind server-side request forgery vulnerability. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker should be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-58441
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 13:50 UTC · Revision 1

Source evidence

Knowage is vulnerable to blind server-side request forgery (SSRF)

core-osv · Original source

Published 7 Jan 2026, 17:16 UTC

Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, there is a blind server-side request forgery vulnerability. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker should be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.

osv:CVE-2025-58441
Complete source record
{
  "id": "d202171ffd5a858f4d8166893df5a37221f6dfdb060a6fd9ea5c14d9c59dc620",
  "url": "https://osv.dev/vulnerability/CVE-2025-58441",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Knowage is vulnerable to blind server-side request forgery (SSRF)",
    "summary": "Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, there is a blind server-side request forgery vulnerability. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker should be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.",
    "evidence": "osv:CVE-2025-58441",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-58441",
      "aliases": [
        "CVE-2025-58441",
        "GHSA-m6x8-wh9v-6jxp"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/knowagelabs/knowage-server",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "13d22c5023e2373044fb0d06a8a91b7429872c30"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "8.1.37"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "8.1.37"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v8.1.36",
            "v8.1.35",
            "v8.1.34",
            "v8.1.32",
            "v8.1.31",
            "v8.1.30",
            "v8.1.29",
            "v8.1.28",
            "v8.1.27",
            "v8.1.26",
            "v8.1.25",
            "v8.1.24",
            "v8.1.23",
            "v8.1.22",
            "v8.1.21",
            "v8.1.20",
            "v8.1.19",
            "v8.1.18",
            "v8.1.17",
            "v8.1.16",
            "v8.1.15",
            "v8.1.12",
            "v8.1.11",
            "v8.1.10",
            "v8.1.9",
            "v8.1.8",
            "v8.1.7",
            "v8.1.6",
            "v8.1.3",
            "v8.1.2",
            "v8.1.1",
            "v8.1.0",
            "v7.2.0",
            "v7.2.0-2020-04-06",
            "v7.0.0-RC"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-58441.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:35.855392900Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58441.json",
        "https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-m6x8-wh9v-6jxp",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-58441"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-918"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58441.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-58441",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 503313,
  "published_at": "2026-01-07T17:16:44.798+00:00"
}