High
Security advisory
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-1000168
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:46 UTC · Revision 1
Source evidence
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
osv:CVE-2018-1000168
Complete source record
{
"id": "59309312e9c93eb9d27807bfa83e4941c70b7646310311179b3a6f7b4f8d0474",
"url": "https://osv.dev/vulnerability/CVE-2018-1000168",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-1000168",
"summary": "nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.",
"evidence": "osv:CVE-2018-1000168",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2018-1000168",
"aliases": [
"CVE-2018-1000168"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/nghttp2/nghttp2",
"type": "GIT",
"events": [
{
"introduced": "918ca4ca7c935dcea4e314949aefb29aa9123093"
},
{
"last_affected": "6e744662310498e97278f46ccbaf6b68a2f2ad6e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:nghttp2:nghttp2:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.10.0"
},
{
"last_affected": "1.31.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.31.0",
"v1.30.0",
"v1.29.0",
"v1.28.0",
"v1.27.0",
"v1.26.0",
"v1.25.0",
"v1.24.0",
"v1.23.0",
"v1.22.0",
"v1.21.0",
"v1.20.0",
"v1.19.0",
"v1.18.0",
"v1.17.0",
"v1.16.0",
"v1.15.0",
"v1.14.0",
"v1.13.0",
"v1.12.0",
"v1.11.0",
"v1.10.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-1000168.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/nodejs/node",
"type": "GIT",
"events": [
{
"introduced": "ce3e3c5fe15479475c068482c48eb9cbf1ac9df5"
},
{
"last_affected": "c6a397bce63fc026421e1515b98eec9b8b5a8468"
},
{
"introduced": "56a0577b2ebf111346779cf790a1f54e0e464078"
},
{
"last_affected": "456bc88c2a16d595e25d5f48ada9646bf21464eb"
},
{
"introduced": "fa9990f3fb5b06fe94e294925246d2c136deb2c2"
},
{
"last_affected": "b5339ff549fcd7ff7f228d00d0ff79b78a347dc6"
},
{
"introduced": "cf41627411886000429bde058a6594fb7f6d6d47"
},
{
"fixed": "1442cfef73c0a7157b1552658529ae9ff9154de9"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*",
"range": [
{
"introduced": "6.0.0"
},
{
"last_affected": "6.8.1"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:*",
"range": [
{
"introduced": "8.4.0"
},
{
"last_affected": "8.17.0"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "9.0.0"
},
{
"last_affected": "9.11.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*",
"range": [
{
"introduced": "10.0.0"
},
{
"fixed": "10.4.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v8.17.0",
"v8.16.2",
"v8.16.1",
"v8.16.0",
"v8.15.1",
"v8.15.0",
"v8.14.1",
"v8.14.0",
"v8.13.0",
"v8.12.0",
"v8.11.4",
"v9.11.2",
"v8.11.3",
"v10.4.0",
"v10.3.0",
"v10.2.1",
"v10.2.0",
"v8.11.2",
"v10.1.0",
"v10.0.0",
"v9.11.1",
"v9.11.0",
"v9.10.1",
"v8.11.1",
"v8.11.0",
"v9.10.0",
"v9.9.0",
"v9.8.0",
"v8.10.0",
"v9.7.1",
"v9.7.0",
"v9.6.1",
"v9.6.0",
"v9.5.0",
"v9.4.0",
"v8.9.4",
"v9.3.0",
"v9.2.1",
"v8.9.3",
"v8.9.2",
"v9.2.0",
"v8.9.1",
"v9.1.0",
"v9.0.0",
"v8.9.0",
"v8.8.1",
"v8.8.0",
"v8.7.0",
"v8.6.0",
"v8.5.0",
"v8.4.0",
"v6.8.1",
"v6.8.0",
"v6.7.0",
"v6.6.0",
"v6.5.0",
"v6.4.0",
"v6.3.1",
"v6.3.0",
"v6.2.2",
"v6.2.1",
"v6.2.0",
"v6.1.0",
"v6.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-1000168.json"
}
}
],
"modified": "2026-10-24T10:30:44.211961759Z",
"provider": "osv",
"references": [
"https://access.redhat.com/errata/RHSA-2019:0366",
"https://access.redhat.com/errata/RHSA-2019:0367",
"https://lists.debian.org/debian-lts-announce/2021/10/msg00011.html",
"https://nghttp2.org/blog/2018/04/12/nghttp2-v1-31-1/",
"https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2018-1000168",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 435818,
"published_at": "2018-05-08T15:29:00.207+00:00"
}