CriticalFix available
Drupal core - Critical - Remote code execution - SA-CORE-2026-014
Type: patchSources: Drupal security
Drupal core contains a remote code execution vulnerability in the Field UI module. The advisory recommends upgrading to the listed fixed versions; uninstalling Field UI is a mitigation while updating.
- Products
- Drupal core
- Affected versions
- >= 8.9.0 < 10.6.19 || >= 11.0.0 < 11.3.19 || >= 11.4.0 < 11.4.10 || >= 12.0.0-alpha1 < 12.0.0-beta2
- Fixed versions
- Drupal 10.6.19, Drupal 11.3.19, Drupal 11.4.10
- CVEs
- CVE-2026-108097
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 12:26 UTC · Revision 1
Source evidence
Drupal core - Critical - Remote code execution - SA-CORE-2026-014
official-drupal-security · Original sourcePublished 14 Oct 2026, 16:10 UTC
Drupal core contains a remote code execution vulnerability in the Field UI module. The advisory recommends upgrading to the listed fixed versions; uninstalling Field UI is a mitigation while updating.
A remote code execution vulnerability exists within the Field UI module in Drupal core.
Drupal core
Fixed versions: Drupal 11.4.10, Drupal 11.3.19, Drupal 10.6.19
Complete source record
{
"id": "b81f0555bfedd604cdf075dc61b228c3ec438ab50e9160aee5bdf07303abb1f1",
"url": "https://www.drupal.org/sa-core-2026-014",
"method": "llm",
"payload": {
"kind": "patch",
"title": "Drupal core - Critical - Remote code execution - SA-CORE-2026-014",
"summary": "Drupal core contains a remote code execution vulnerability in the Field UI module. The advisory recommends upgrading to the listed fixed versions; uninstalling Field UI is a mitigation while updating.",
"evidence": "A remote code execution vulnerability exists within the Field UI module in Drupal core.",
"products": [
{
"name": {
"value": "Drupal core",
"evidence": "Project: Drupal core"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "Drupal 11.4.10",
"evidence": "If you use Drupal 11.4.x, update to Drupal 11.4.10."
},
{
"value": "Drupal 11.3.19",
"evidence": "If you use Drupal 11.3.x, update to Drupal 11.3.19."
},
{
"value": "Drupal 10.6.19",
"evidence": "If you use Drupal 10.6.x, update to Drupal 10.6.19."
}
],
"affected_versions": [
{
"value": ">= 8.9.0 < 10.6.19 || >= 11.0.0 < 11.3.19 || >= 11.4.0 < 11.4.10 || >= 12.0.0-alpha1 < 12.0.0-beta2",
"evidence": "Affected versions: >= 8.9.0 < 10.6.19 || >= 11.0.0 < 11.3.19 || >= 11.4.0 < 11.4.10 || >= 12.0.0-alpha1 < 12.0.0-beta2"
}
]
}
],
"severity": "critical",
"fixed_cves": [],
"related_cves": [
{
"value": "CVE-2026-108097",
"evidence": "CVE IDs: CVE-2026-108097"
}
],
"security_relevant": true,
"severity_evidence": "Security risk: Critical"
},
"source_id": "official-drupal-security",
"document_id": 23453,
"published_at": "2026-10-14T16:10:00+00:00"
}