Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-29439

The Grav admin plugin prior to version 1.10.11 does not correctly verify caller's privileges. As a consequence, users with the permission `admin.login` can install third-party plugins and their dependencies. By installing the right plugin, an attacker can obtain an arbitrary code execution primitive and elevate their privileges on the instance. The vulnerability has been addressed in version 1.10.11. As a mitigation blocking access to the `/admin` path from untrusted sources will reduce the probability of exploitation.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-29439
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:43 UTC · Revision 1

Source evidence

CVE-2021-29439

core-osv · Original source

Published 13 Apr 2021, 20:15 UTC

The Grav admin plugin prior to version 1.10.11 does not correctly verify caller's privileges. As a consequence, users with the permission `admin.login` can install third-party plugins and their dependencies. By installing the right plugin, an attacker can obtain an arbitrary code execution primitive and elevate their privileges on the instance. The vulnerability has been addressed in version 1.10.11. As a mitigation blocking access to the `/admin` path from untrusted sources will reduce the probability of exploitation.

osv:CVE-2021-29439
Complete source record
{
  "id": "eba252dda309f011d946cb3cbd741e10e5ca0c0db9aa4673bbcab2fd5a8f3327",
  "url": "https://osv.dev/vulnerability/CVE-2021-29439",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-29439",
    "summary": "The Grav admin plugin prior to version 1.10.11 does not correctly verify caller's privileges. As a consequence, users with the permission `admin.login` can install third-party plugins and their dependencies. By installing the right plugin, an attacker can obtain an arbitrary code execution primitive and elevate their privileges on the instance. The vulnerability has been addressed in version 1.10.11. As a mitigation blocking access to the `/admin` path from untrusted sources will reduce the probability of exploitation.",
    "evidence": "osv:CVE-2021-29439",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2021-29439",
      "aliases": [
        "CVE-2021-29439",
        "GHSA-wg37-cf5x-55hq"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/getgrav/grav-plugin-admin",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "a220359877fd1281f76ba732e5308e0e3002e4b1"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "fixed": "a220359877fd1281f76ba732e5308e0e3002e4b1"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.10.10",
            "1.10.9",
            "1.10.8",
            "1.10.7",
            "1.10.6",
            "1.10.5",
            "1.10.4",
            "1.10.3",
            "1.10.2",
            "1.10.1",
            "1.10.0",
            "1.9.19",
            "1.9.18",
            "1.9.17",
            "1.9.16",
            "1.9.15",
            "1.9.14",
            "1.9.13",
            "1.9.12",
            "1.9.10",
            "1.9.9",
            "1.9.8",
            "1.9.7",
            "1.9.6",
            "1.9.5",
            "1.9.4",
            "1.9.3",
            "1.9.2",
            "1.9.1",
            "1.9.0",
            "1.8.20",
            "1.8.19",
            "1.8.18",
            "1.8.17",
            "1.8.16",
            "1.8.15",
            "1.8.14",
            "1.8.13",
            "1.8.12",
            "1.8.11",
            "1.8.10",
            "1.8.9",
            "1.8.8",
            "1.8.7",
            "1.8.6",
            "1.8.5",
            "1.8.4",
            "1.8.3",
            "1.8.2",
            "1.8.1",
            "1.8.0",
            "1.7.4",
            "1.7.3",
            "1.7.2",
            "1.7.1",
            "1.7.0",
            "1.6.7",
            "1.6.6",
            "1.6.5",
            "1.6.4",
            "1.6.3",
            "1.6.2",
            "1.6.1",
            "1.6.0",
            "1.5.2",
            "1.5.1",
            "1.5.0",
            "1.4.2",
            "1.4.1",
            "1.4.0",
            "1.3.3",
            "1.3.2",
            "1.3.1",
            "1.3.0",
            "1.2.14",
            "1.2.13",
            "1.2.12",
            "1.2.5-rc.4",
            "1.2.5-rc.3",
            "1.2.5-rc.2",
            "1.2.5-rc.1",
            "1.2.0-rc.2",
            "1.2.0-rc.1",
            "1.1.0-rc.4",
            "1.1.0-rc.3",
            "1.1.0-rc.2",
            "1.1.0-rc.1",
            "1.1.0-beta.5",
            "1.1.0-beta.4",
            "1.1.0-beta.3",
            "1.1.0-beta.2",
            "1.1.0-beta.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-29439.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:37.103304092Z",
      "provider": "osv",
      "references": [
        "https://github.com/getgrav/grav-plugin-admin/security/advisories/GHSA-wg37-cf5x-55hq",
        "https://github.com/getgrav/grav-plugin-admin/commit/a220359877fd1281f76ba732e5308e0e3002e4b1"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:a:getgrav:grav_admin:*:*:*:*:*:*:*:*"
            ],
            "vendor_product": "getgrav:grav_admin",
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "1.10.11"
                  }
                ],
                "source": "CPE_RANGE"
              }
            ]
          },
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "1.10.11"
                  }
                ],
                "source": "DESCRIPTION"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2021-29439",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385746,
  "published_at": "2021-04-13T20:15:22.297+00:00"
}