Security advisory
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 a new budget type can be defined by user. This input is not correctly filtered. This results in a cross-site scripting attack. To exploit this endpoint attacker need to be authenticated. This is fixed in version 9.5.4.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-21325
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:32 UTC · Revision 1
Source evidence
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 a new budget type can be defined by user. This input is not correctly filtered. This results in a cross-site scripting attack. To exploit this endpoint attacker need to be authenticated. This is fixed in version 9.5.4.
osv:CVE-2021-21325
Complete source record
{
"id": "6167c3c93bc5d91b37798fc02a6e97d23d997cc2e5d7f3808838fde1d2571caa",
"url": "https://osv.dev/vulnerability/CVE-2021-21325",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-21325",
"summary": "GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 a new budget type can be defined by user. This input is not correctly filtered. This results in a cross-site scripting attack. To exploit this endpoint attacker need to be authenticated. This is fixed in version 9.5.4.",
"evidence": "osv:CVE-2021-21325",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-21325",
"aliases": [
"CVE-2021-21325",
"GHSA-m574-f3jw-pwrf"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/glpi-project/glpi",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "59a0a0b6101fcd54b00bfc6a61d4e707513c08c9"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "9.5.4"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "59a0a0b6101fcd54b00bfc6a61d4e707513c08c9"
}
],
"source": "REFERENCES_TAG",
"original_tag": "9.5.4"
}
]
}
}
],
"versions": [
"9.5.3",
"9.5.2",
"9.5.1",
"9.5.0",
"9.5.0-rc2",
"9.5.0-rc1",
"9.4.1.1",
"9.4.1",
"9.4.0",
"9.4.0-rc2",
"9.4.0-rc1",
"9.4.0-beta",
"9.3-beta",
"9.1",
"9.1-RC2",
"9.1-RC1",
"0.90",
"0.90-RC2",
"0.90-RC1",
"0.90-beta2",
"0.90-beta1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21325.json"
}
}
],
"modified": "2026-10-20T10:54:28.087062750Z",
"provider": "osv",
"references": [
"https://github.com/glpi-project/glpi/releases/tag/9.5.4",
"https://github.com/glpi-project/glpi/security/advisories/GHSA-m574-f3jw-pwrf"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-21325",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385403,
"published_at": "2021-03-08T17:15:12.96+00:00"
}