High
Security advisory
The Gentoo app-backup/burp package before 2.1.32 has incorrect group ownership of the /etc/burp directory, which might allow local users to obtain read and write access to arbitrary files by leveraging access to a certain account for a burp-server.conf change.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-18285
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:36 UTC · Revision 1
Source evidence
The Gentoo app-backup/burp package before 2.1.32 has incorrect group ownership of the /etc/burp directory, which might allow local users to obtain read and write access to arbitrary files by leveraging access to a certain account for a burp-server.conf change.
osv:CVE-2017-18285
Complete source record
{
"id": "c0d726bbf1259cea1bba2a70119c0b0eea3fe6bf901f34695273af2484140062",
"url": "https://osv.dev/vulnerability/CVE-2017-18285",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-18285",
"summary": "The Gentoo app-backup/burp package before 2.1.32 has incorrect group ownership of the /etc/burp directory, which might allow local users to obtain read and write access to arbitrary files by leveraging access to a certain account for a burp-server.conf change.",
"evidence": "osv:CVE-2017-18285",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2017-18285",
"aliases": [
"CVE-2017-18285"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/grke/burp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "2f1150cf348454eae4546be7854c50fc8bf71c52"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:burp_project:burp:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.1.32"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.1.30",
"2.1.28",
"2.1.26",
"2.1.24",
"2.1.22",
"2.1.20",
"2.1.18",
"2.1.14",
"2.1.12",
"2.1.10",
"2.1.8",
"2.1.6",
"2.1.4",
"2.1.2",
"2.1.0",
"2.0.52",
"2.0.50",
"2.0.48",
"2.0.44",
"2.0.42",
"2.0.40",
"2.0.38",
"2.0.36",
"2.0.34",
"2.0.32",
"2.0.30",
"2.0.28",
"2.0.24",
"2.0.22",
"2.0.20",
"1.3.32",
"1.3.30",
"1.3.28",
"1.3.26",
"1.3.24",
"1.3.22",
"1.3.20",
"1.3.18",
"1.3.16",
"1.3.14",
"1.3.12",
"1.3.10",
"1.3.8",
"1.3.6",
"1.3.4",
"1.3.0",
"1.2.8",
"1.2.7",
"1.2.6",
"1.2.5",
"1.2.4",
"1.2.3",
"1.2.2",
"1.2.0",
"1.1.70",
"1.1.65",
"1.1.57",
"1.1.55",
"1.1.51",
"1.1.40"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-18285.json"
}
}
],
"modified": "2026-10-24T10:30:20.733422819Z",
"provider": "osv",
"references": [
"https://security.gentoo.org/glsa/201806-03",
"https://security.gentoo.org/glsa/201904-05",
"https://bugs.gentoo.org/641842"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2017-18285",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 430331,
"published_at": "2018-06-04T06:29:00.327+00:00"
}