Libarchive: integer overflow while reading warc files at archive_read_support_format_warc.c
A vulnerability has been identified in the libarchive library. This flaw involves an integer overflow that can be triggered when processing a Web Archive (WARC) file that claims to have more than INT64_MAX - 4 content bytes. An attacker could craft a malicious WARC archive to induce this overflow, potentially leading to unpredictable program behavior, memory corruption, or a denial-of-service condition within applications that process such archives using libarchive. This bug affects libarchive versions prior to 3.8.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-5916
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 19:49 UTC · Revision 1
Source evidence
Libarchive: integer overflow while reading warc files at archive_read_support_format_warc.c
core-osv · Original sourcePublished 9 Jun 2025, 19:49 UTC
A vulnerability has been identified in the libarchive library. This flaw involves an integer overflow that can be triggered when processing a Web Archive (WARC) file that claims to have more than INT64_MAX - 4 content bytes. An attacker could craft a malicious WARC archive to induce this overflow, potentially leading to unpredictable program behavior, memory corruption, or a denial-of-service condition within applications that process such archives using libarchive. This bug affects libarchive versions prior to 3.8.0.
osv:CVE-2025-5916
Complete source record
{
"id": "7689c29a25032af82020cfbc4d88d132482ecee7d2929f297bcaa4dd8c392c1d",
"url": "https://osv.dev/vulnerability/CVE-2025-5916",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Libarchive: integer overflow while reading warc files at archive_read_support_format_warc.c",
"summary": "A vulnerability has been identified in the libarchive library. This flaw involves an integer overflow that can be triggered when processing a Web Archive (WARC) file that claims to have more than INT64_MAX - 4 content bytes. An attacker could craft a malicious WARC archive to induce this overflow, potentially leading to unpredictable program behavior, memory corruption, or a denial-of-service condition within applications that process such archives using libarchive. This bug affects libarchive versions prior to 3.8.0.",
"evidence": "osv:CVE-2025-5916",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2025-5916",
"aliases": [
"CVE-2025-5916"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/libarchive/libarchive",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "70ff28fcf04ec129a1d064f96e49aa57fcc90e37"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "3.8.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"fixed": "70ff28fcf04ec129a1d064f96e49aa57fcc90e37"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v3.8.0"
},
{
"cpe": "cpe:2.3:a:libarchive:libarchive:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.8.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.7.5",
"v3.7.4",
"v3.7.3",
"v3.7.2",
"v3.7.1",
"v3.7.0",
"v3.6.2",
"v3.6.1",
"v3.6.0",
"v3.5.2",
"v3.5.1",
"v3.5.0",
"v3.4.3",
"v3.4.2",
"v3.4.1",
"v3.4.0",
"v3.3.3",
"v3.3.2",
"v3.3.1",
"v3.3.0",
"v3.2.2",
"v3.2.1",
"v3.2.0",
"v3.1.900a",
"v3.0.1b",
"v3.0.0a"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-5916.json"
}
}
],
"modified": "2026-10-28T02:30:51.503937656Z",
"provider": "osv",
"references": [
"https://access.redhat.com/downloads/content/package-browser/",
"https://github.com/libarchive/libarchive/",
"https://github.com/libarchive/libarchive/releases/tag/v3.8.0",
"https://access.redhat.com/security/cve/CVE-2025-5916",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/5xxx/CVE-2025-5916.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-5916",
"https://bugzilla.redhat.com/show_bug.cgi?id=2370872",
"https://github.com/libarchive/libarchive/pull/2568"
],
"provider_metadata": {
"cwe_ids": [
"CWE-190"
],
"cna_assigner": "redhat",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/5xxx/CVE-2025-5916.json"
}
},
"related_cves": [
{
"value": "CVE-2025-5916",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 520258,
"published_at": "2025-06-09T19:49:07.62+00:00"
}