Medium
WordPress Everest Forms Plugin <= 2.0.4.1 is vulnerable to Cross Site Scripting (XSS)
Type: advisorySources: OSV
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPEverest Everest Forms – Build Contact Forms, Surveys, Polls, Application Forms, and more with Ease! allows Stored XSS.This issue affects Everest Forms – Build Contact Forms, Surveys, Polls, Application Forms, and more with Ease!: from n/a through 2.0.4.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-51695
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 20:38 UTC · Revision 1
Source evidence
WordPress Everest Forms Plugin <= 2.0.4.1 is vulnerable to Cross Site Scripting (XSS)
core-osv · Original sourcePublished 1 Feb 2024, 11:07 UTC
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPEverest Everest Forms – Build Contact Forms, Surveys, Polls, Application Forms, and more with Ease! allows Stored XSS.This issue affects Everest Forms – Build Contact Forms, Surveys, Polls, Application Forms, and more with Ease!: from n/a through 2.0.4.1.
osv:CVE-2023-51695
Complete source record
{
"id": "8b331f83358c73f7526ff4914301d302eda223477f4e15a6b4e08625afdb2d21",
"url": "https://osv.dev/vulnerability/CVE-2023-51695",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress Everest Forms Plugin <= 2.0.4.1 is vulnerable to Cross Site Scripting (XSS)",
"summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPEverest Everest Forms – Build Contact Forms, Surveys, Polls, Application Forms, and more with Ease! allows Stored XSS.This issue affects Everest Forms – Build Contact Forms, Surveys, Polls, Application Forms, and more with Ease!: from n/a through 2.0.4.1.",
"evidence": "osv:CVE-2023-51695",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-51695",
"aliases": [
"CVE-2023-51695"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/themegrill/everest-forms",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "55cbf250e70c30211fa16551ef95fa19e2934278"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wpeverest:everest_forms:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "2.0.4.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.0.4.1",
"2.0.4",
"2.0.3.1",
"2.0.3",
"2.0.1",
"2.0.0.1",
"2.0.0",
"1.9.9",
"1.9.8",
"1.9.7",
"1.9.6",
"1.9.5",
"1.9.4.1",
"1.9.4",
"1.9.3",
"1.9.2",
"1.9.1",
"1.9.0.1",
"1.9.0",
"1.8.9",
"1.8.8",
"1.8.7",
"1.8.6",
"1.8.5",
"1.8.4",
"1.8.3",
"1.8.2.3",
"1.8.2.2",
"1.8.2.1",
"1.8.2",
"1.8.1",
"1.8.0.1",
"1.8.0",
"1.7.9",
"1.7.8",
"1.7.7.2",
"1.7.7.1",
"1.7.7",
"1.7.6",
"1.7.5.2",
"1.7.5.1",
"1.7.5",
"1.7.4",
"1.7.3",
"1.7.2.2",
"1.7.2.1",
"1.7.2",
"1.7.1",
"1.7.0.3",
"1.7.0.2",
"1.7.0.1",
"1.7.0",
"1.6.7",
"1.6.6.1",
"1.6.6",
"1.6.5",
"1.6.4",
"1.6.2",
"1.6.3",
"1.6.1",
"1.6.0",
"1.5.10",
"1.5.9",
"1.5.8",
"1.5.7",
"1.5.6",
"1.5.5",
"1.5.4",
"1.5.2",
"1.5.1",
"1.5.0",
"1.4.9",
"1.4.8",
"1.4.6",
"1.4.5",
"1.4.4",
"1.4.3",
"1.4.2",
"1.4.1",
"1.4.0-beta6",
"1.4.0",
"1.4.0-beta5",
"1.4.0-beta4",
"1.4.0-beta3",
"1.4.0-beta2",
"v1.4.0-beta",
"1.4.0-beta",
"1.3.4",
"1.3.2",
"1.3.0",
"1.2.0",
"1.2.0-rc.1",
"1.1.4",
"1.1.3",
"1.1.0",
"1.1.0-rc.1",
"1.0.2",
"1.0.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-51695.json"
}
}
],
"modified": "2026-10-28T02:30:39.084249028Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/51xxx/CVE-2023-51695.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-51695",
"https://patchstack.com/database/vulnerability/everest-forms/wordpress-everest-forms-plugin-2-0-4-1-cross-site-scripting-xss-vulnerability?_s_id=cve"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Patchstack",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "2.0.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "ChangesAt"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/51xxx/CVE-2023-51695.json"
}
},
"related_cves": [
{
"value": "CVE-2023-51695",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 506769,
"published_at": "2024-02-01T11:07:21.238+00:00"
}