tomcat10, tomcat9 — security advisory
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.
- Products
- tomcat10, tomcat9
- Affected versions
- 10.1.6-1, 10.1.6-1+deb12u1
- Fixed versions
- 10.1.16-1, 10.1.6-1+deb12u2, 9.0.70-2
- CVEs
- CVE-2023-46589
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:41 UTC · Revision 1
Source evidence
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.
osv:DEBIAN-CVE-2023-46589
tomcat10
Fixed versions: 10.1.6-1+deb12u2
tomcat10
Fixed versions: 10.1.16-1
tomcat10
Fixed versions: 10.1.16-1
tomcat9
Fixed versions: 9.0.70-2
tomcat9
Fixed versions: 9.0.70-2
tomcat9
Fixed versions: 9.0.70-2
Complete source record
{
"id": "5d2523e06f74e9ad698cbd8bbecbe38949b4fb64e7f20109d0805cfe385f3847",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-46589",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-46589",
"summary": "Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.",
"evidence": "osv:DEBIAN-CVE-2023-46589",
"products": [
{
"name": {
"value": "tomcat10",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "10.1.6-1+deb12u2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "10.1.6-1",
"evidence": "/affected/0/versions"
},
{
"value": "10.1.6-1+deb12u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "tomcat10",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "10.1.16-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "tomcat10",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "10.1.16-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "tomcat9",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.0.70-2",
"evidence": "/affected/3/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "tomcat9",
"evidence": "/affected/4/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.0.70-2",
"evidence": "/affected/4/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "tomcat9",
"evidence": "/affected/5/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.0.70-2",
"evidence": "/affected/5/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-46589",
"aliases": [
"DEBIAN-CVE-2023-46589"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "10.1.6-1+deb12u2"
}
]
}
],
"package": {
"name": "tomcat10",
"purl": "pkg:deb/debian/tomcat10?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"10.1.6-1",
"10.1.6-1+deb12u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-46589.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "10.1.16-1"
}
]
}
],
"package": {
"name": "tomcat10",
"purl": "pkg:deb/debian/tomcat10?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-46589.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "10.1.16-1"
}
]
}
],
"package": {
"name": "tomcat10",
"purl": "pkg:deb/debian/tomcat10?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-46589.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.0.70-2"
}
]
}
],
"package": {
"name": "tomcat9",
"purl": "pkg:deb/debian/tomcat9?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-46589.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.0.70-2"
}
]
}
],
"package": {
"name": "tomcat9",
"purl": "pkg:deb/debian/tomcat9?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-46589.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.0.70-2"
}
]
}
],
"package": {
"name": "tomcat9",
"purl": "pkg:deb/debian/tomcat9?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-46589.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:01:28.178486625Z",
"provider": "osv",
"upstream": [
"CVE-2023-46589"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-46589"
]
},
"related_cves": [
{
"value": "CVE-2023-46589",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 455525,
"published_at": "2023-11-28T16:15:06.943+00:00"
}