Skip to content
Heist/ feed
Back to feed
MediumFix available

jqueryui — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-31160

jQuery UI is a curated set of user interface interactions, effects, widgets, and themes built on top of jQuery. Versions prior to 1.13.2 are potentially vulnerable to cross-site scripting. Initializing a checkboxradio widget on an input enclosed within a label makes that parent label contents considered as the input label. Calling `.checkboxradio( "refresh" )` on such a widget and the initial HTML contained encoded HTML entities will make them erroneously get decoded. This can lead to potentially executing JavaScript code. The bug has been patched in jQuery UI 1.13.2. To remediate the issue, someone who can change the initial HTML can wrap all the non-input contents of the `label` in a `span`.

Products
jqueryui
Affected versions
Not specified
Fixed versions
1.13.2+dfsg-1
CVEs
CVE-2022-31160
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:44 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-31160

core-osv · Original source

Published 20 Jul 2022, 20:15 UTC

jQuery UI is a curated set of user interface interactions, effects, widgets, and themes built on top of jQuery. Versions prior to 1.13.2 are potentially vulnerable to cross-site scripting. Initializing a checkboxradio widget on an input enclosed within a label makes that parent label contents considered as the input label. Calling `.checkboxradio( "refresh" )` on such a widget and the initial HTML contained encoded HTML entities will make them erroneously get decoded. This can lead to potentially executing JavaScript code. The bug has been patched in jQuery UI 1.13.2. To remediate the issue, someone who can change the initial HTML can wrap all the non-input contents of the `label` in a `span`.

osv:DEBIAN-CVE-2022-31160

jqueryui

Fixed versions: 1.13.2+dfsg-1

jqueryui

Fixed versions: 1.13.2+dfsg-1

jqueryui

Fixed versions: 1.13.2+dfsg-1

Complete source record
{
  "id": "85eb28046243dc057619e230dfacd9593ae26e61655e2d999d6d4587a1e3e54c",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-31160",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-31160",
    "summary": "jQuery UI is a curated set of user interface interactions, effects, widgets, and themes built on top of jQuery. Versions prior to 1.13.2 are potentially vulnerable to cross-site scripting. Initializing a checkboxradio widget on an input enclosed within a label makes that parent label contents considered as the input label. Calling `.checkboxradio( \"refresh\" )` on such a widget and the initial HTML contained encoded HTML entities will make them erroneously get decoded. This can lead to potentially executing JavaScript code. The bug has been patched in jQuery UI 1.13.2. To remediate the issue, someone who can change the initial HTML can wrap all the non-input contents of the `label` in a `span`.",
    "evidence": "osv:DEBIAN-CVE-2022-31160",
    "products": [
      {
        "name": {
          "value": "jqueryui",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.13.2+dfsg-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "jqueryui",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.13.2+dfsg-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "jqueryui",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.13.2+dfsg-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2022-31160",
      "aliases": [
        "DEBIAN-CVE-2022-31160"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.13.2+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "jqueryui",
            "purl": "pkg:deb/debian/jqueryui?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-31160.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.13.2+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "jqueryui",
            "purl": "pkg:deb/debian/jqueryui?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-31160.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.13.2+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "jqueryui",
            "purl": "pkg:deb/debian/jqueryui?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-31160.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:01:51.470108219Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-31160"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-31160"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-31160",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323173,
  "published_at": "2022-07-20T20:15:08.053+00:00"
}