Skip to content
Heist/ feed
Back to feed
Unrated

Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp

Type: advisorySources: OSV

A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-28730
Confirmed fixed CVEs
Not specified
Updated in this feed
5 Nov 2026, 00:52 UTC · Revision 1

Source evidence

Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp

core-osv · Original source

Published 4 Aug 2022, 06:15 UTC

A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.

osv:CVE-2022-28730
Complete source record
{
  "id": "0ac7d0be1eb157624065aeeac925dbdfe05f1f8bc07f839adae8f0a8ba23c6ea",
  "url": "https://osv.dev/vulnerability/CVE-2022-28730",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp",
    "summary": "A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.",
    "evidence": "osv:CVE-2022-28730",
    "products": [],
    "severity": "unknown",
    "structured": {
      "id": "CVE-2022-28730",
      "aliases": [
        "CVE-2022-28730",
        "GHSA-ggjq-8c4c-68r5"
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/jspwiki",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "515dff39c66c43318056fa76a20117662d2a0e8d"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.11.3"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.11.2-RC1",
            "2.11.2",
            "2.11.1-RC1",
            "2.11.1",
            "2.11.0-RC2",
            "2.11.0",
            "2.11.0-RC1",
            "2.11.0.M8-RC1",
            "2.11.0.M8",
            "2.11.0.M7-RC1",
            "2.11.0.M7",
            "2.11.0.M6-RC1",
            "2.11.0.M6",
            "2.11.0.M5-RC3",
            "2.11.0.M5",
            "2.11.0.M5-RC2",
            "2.11.0.M5-RC1",
            "2.11.0.M4-RC2",
            "2.11.0.M4",
            "2.11.0.M4-RC1",
            "2.11.0.M3-RC2",
            "2.11.0.M3",
            "2.11.0.M3-RC1",
            "2.11.0.M2-RC1",
            "2.11.0.M2",
            "2.11.0.M1.RC3",
            "2.11.0.M1",
            "2.11.0.M1-RC2",
            "2.11.0.M1-RC1",
            "2.10.5-RC2",
            "2.10.5",
            "2.10.5-RC1",
            "2.10.4-RC3",
            "2.10.4",
            "2.10.4-RC2",
            "2.10.4-RC1",
            "2.10.3-RC2",
            "2.10.3",
            "2.10.3-RC1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-28730.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:40.930016706Z",
      "provider": "osv",
      "references": [
        "https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-28732",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/28xxx/CVE-2022-28730.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-28730"
      ],
      "provider_metadata": {
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "Apache JSPWiki"
                  },
                  {
                    "last_affected": "Apache JSPWiki up to 2.11.2"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/28xxx/CVE-2022-28730.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-28730",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 508721,
  "published_at": "2022-08-04T06:15:29+00:00"
}