Contact Form 7 <= 5.8.3 - Authenticated (Editor+) Arbitrary File Upload
The Contact Form 7 plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'validate' function and insufficient blocklisting on the 'wpcf7_antiscript_file_name' function in versions up to, and including, 5.8.3. This makes it possible for authenticated attackers with editor-level capabilities or above to upload arbitrary files on the affected site's server, but due to the htaccess configuration, remote code cannot be executed in most cases. By default, the file will be deleted from the server immediately. However, in some cases, other plugins may make it possible for the file to live on the server longer. This can make remote code execution possible when combined with another vulnerability, such as local file inclusion.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-6449
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 20:49 UTC · Revision 1
Source evidence
Contact Form 7 <= 5.8.3 - Authenticated (Editor+) Arbitrary File Upload
core-osv · Original sourcePublished 1 Dec 2023, 11:00 UTC
The Contact Form 7 plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'validate' function and insufficient blocklisting on the 'wpcf7_antiscript_file_name' function in versions up to, and including, 5.8.3. This makes it possible for authenticated attackers with editor-level capabilities or above to upload arbitrary files on the affected site's server, but due to the htaccess configuration, remote code cannot be executed in most cases. By default, the file will be deleted from the server immediately. However, in some cases, other plugins may make it possible for the file to live on the server longer. This can make remote code execution possible when combined with another vulnerability, such as local file inclusion.
osv:CVE-2023-6449
Complete source record
{
"id": "85f5cf8cf36970a3d06a1b0506f90c5d5d267627597877cff1a2a79bf4842d3f",
"url": "https://osv.dev/vulnerability/CVE-2023-6449",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Contact Form 7 <= 5.8.3 - Authenticated (Editor+) Arbitrary File Upload",
"summary": "The Contact Form 7 plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'validate' function and insufficient blocklisting on the 'wpcf7_antiscript_file_name' function in versions up to, and including, 5.8.3. This makes it possible for authenticated attackers with editor-level capabilities or above to upload arbitrary files on the affected site's server, but due to the htaccess configuration, remote code cannot be executed in most cases. By default, the file will be deleted from the server immediately. However, in some cases, other plugins may make it possible for the file to live on the server longer. This can make remote code execution possible when combined with another vulnerability, such as local file inclusion.",
"evidence": "osv:CVE-2023-6449",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-6449",
"aliases": [
"CVE-2023-6449"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/rocklobster-in/contact-form-7",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "7bb6134da7917fef23cd185831574c264fe6b1f0"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"last_affected": "5.8.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:rocklobster:contact_form_7:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.8.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v5.8.3",
"v5.8.1",
"v5.8.0",
"v5.7.7",
"v5.7.6",
"v5.7.5.1",
"v5.7.5",
"v5.7.4",
"v5.7.3",
"v5.7.2",
"v5.7.1",
"v5.7",
"v5.6.3",
"v5.6.2",
"v5.6.1",
"v5.6",
"v5.6-beta",
"v5.6-alpha",
"v5.5.6",
"v5.5.5",
"v5.5.4",
"v5.5.3",
"v5.5.2",
"v5.5.1",
"v5.5",
"v5.4.2",
"v5.4.1",
"v5.4",
"v5.4-beta2",
"v5.4-beta",
"v5.3.1",
"v5.3",
"v5.2.2",
"v5.2.1",
"v5.2",
"v5.1.9",
"v5.1.8",
"v5.1.7",
"v5.1.6"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-6449.json"
}
}
],
"modified": "2026-10-28T02:30:23.754716599Z",
"provider": "osv",
"references": [
"https://contactform7.com/2023/11/30/contact-form-7-584/",
"https://github.com/rocklobster-in/contact-form-7/compare/v5.8.3...v5.8.4",
"https://plugins.trac.wordpress.org/browser/contact-form-7/tags/5.8.3/includes/formatting.php#L275",
"https://plugins.trac.wordpress.org/changeset/3003556/contact-form-7",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/5d7fb020-6acb-445e-a46b-bdb5aaf8f2b6?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/6xxx/CVE-2023-6449.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-6449"
],
"provider_metadata": {
"cwe_ids": [
"CWE-434"
],
"cna_assigner": "Wordfence",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/6xxx/CVE-2023-6449.json"
}
},
"related_cves": [
{
"value": "CVE-2023-6449",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 490013,
"published_at": "2023-12-01T11:00:06.019+00:00"
}