Inefficient Regular Expression Complexity in v8n
v8n is a javascript validation library. Versions of v8n prior to 1.5.1 were found to have an inefficient regular expression complexity in the `lowercase()` and `uppercase()` regex which could lead to a denial of service attack. In testing of the `lowercase()` function a payload of 'a' + 'a'.repeat(i) + 'A' with 32 leading characters took 29443 ms to execute. The same issue happens with uppercase(). Users are advised to upgrade. There are no known workarounds for this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-35923
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 19:10 UTC · Revision 1
Source evidence
Inefficient Regular Expression Complexity in v8n
core-osv · Original sourcePublished 2 Aug 2022, 20:10 UTC
v8n is a javascript validation library. Versions of v8n prior to 1.5.1 were found to have an inefficient regular expression complexity in the `lowercase()` and `uppercase()` regex which could lead to a denial of service attack. In testing of the `lowercase()` function a payload of 'a' + 'a'.repeat(i) + 'A' with 32 leading characters took 29443 ms to execute. The same issue happens with uppercase(). Users are advised to upgrade. There are no known workarounds for this issue.
osv:CVE-2022-35923
Complete source record
{
"id": "154fcafa299bcb4f8ea4346b0fb6efb25d89030a3cfbeedda72a8af6c9c2157a",
"url": "https://osv.dev/vulnerability/CVE-2022-35923",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Inefficient Regular Expression Complexity in v8n",
"summary": "v8n is a javascript validation library. Versions of v8n prior to 1.5.1 were found to have an inefficient regular expression complexity in the `lowercase()` and `uppercase()` regex which could lead to a denial of service attack. In testing of the `lowercase()` function a payload of 'a' + 'a'.repeat(i) + 'A' with 32 leading characters took 29443 ms to execute. The same issue happens with uppercase(). Users are advised to upgrade. There are no known workarounds for this issue.",
"evidence": "osv:CVE-2022-35923",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-35923",
"aliases": [
"CVE-2022-35923",
"GHSA-xrx9-gj26-5wx9"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/imbrn/v8n",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "60afb53baab7c2e8de4dd9141633753a3a018a39"
},
{
"fixed": "92393862156fad190c05ec3f6e2bc73308dcd2f9"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:v8n_project:v8n:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.5.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "92393862156fad190c05ec3f6e2bc73308dcd2f9"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.5.0",
"v1.4.0",
"v1.3.3",
"v1.3.2",
"v1.3.1",
"v1.3.0",
"v1.2.1",
"v1.2.0",
"v1.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-35923.json"
}
}
],
"modified": "2026-10-28T02:30:38.591813410Z",
"provider": "osv",
"references": [
"https://huntr.dev/bounties/2d92f644-593b-43b4-bfd1-c8042ac60609/",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/35xxx/CVE-2022-35923.json",
"https://github.com/imbrn/v8n/security/advisories/GHSA-xrx9-gj26-5wx9",
"https://nvd.nist.gov/vuln/detail/CVE-2022-35923",
"https://github.com/imbrn/v8n/commit/92393862156fad190c05ec3f6e2bc73308dcd2f9"
],
"provider_metadata": {
"cwe_ids": [
"CWE-400"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/35xxx/CVE-2022-35923.json"
}
},
"related_cves": [
{
"value": "CVE-2022-35923",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 506018,
"published_at": "2022-08-02T20:10:11+00:00"
}