Critical
Security advisory
Drupal core 8 before versions 8.3.4 allows remote attackers to execute arbitrary code due to the PECL YAML parser not handling PHP objects safely during certain operations.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-6920
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:51 UTC · Revision 1
Source evidence
Drupal core 8 before versions 8.3.4 allows remote attackers to execute arbitrary code due to the PECL YAML parser not handling PHP objects safely during certain operations.
osv:CVE-2017-6920
Complete source record
{
"id": "ffe89788d4d02e3ba0b0499d099d3c5ac1084b6186c9e61aa4fa087a5ce7e2b0",
"url": "https://osv.dev/vulnerability/CVE-2017-6920",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-6920",
"summary": "Drupal core 8 before versions 8.3.4 allows remote attackers to execute arbitrary code due to the PECL YAML parser not handling PHP objects safely during certain operations.",
"evidence": "osv:CVE-2017-6920",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2017-6920",
"aliases": [
"CVE-2017-6920",
"GHSA-9c24-g32g-35rj"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/drupal/drupal",
"type": "GIT",
"events": [
{
"introduced": "35c2f3ca5c935f3d8bde15932a712677c9bbd50f"
},
{
"fixed": "a795651d0b60a8a5d4867223fbc10bcbdfb5ee87"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.3.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"8.3.3",
"8.3.2",
"8.3.0",
"8.3.0-rc2",
"8.3.0-rc1",
"8.3.0-beta1",
"8.3.0-alpha1",
"8.1.0-beta1",
"8.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-6920.json"
}
}
],
"modified": "2026-10-24T10:30:45.529239404Z",
"provider": "osv",
"references": [
"https://www.drupal.org/forum/newsletters/security-advisories-for-drupal-core/2017-06-21/drupal-core-multiple"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2017-6920",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 436134,
"published_at": "2018-08-06T15:29:00.237+00:00"
}