Medium
Security advisory
phpIPAM version 1.3.2 and earlier contains a Cross Site Scripting (XSS) vulnerability in subnet-scan-telnet.php that can result in executing code in victims browser. This attack appears to be exploitable via victim visits link crafted by an attacker. This vulnerability appears to have been fixed in 1.4.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-1000010
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:31 UTC · Revision 1
Source evidence
phpIPAM version 1.3.2 and earlier contains a Cross Site Scripting (XSS) vulnerability in subnet-scan-telnet.php that can result in executing code in victims browser. This attack appears to be exploitable via victim visits link crafted by an attacker. This vulnerability appears to have been fixed in 1.4.
osv:CVE-2019-1000010
Complete source record
{
"id": "4627de1490a052fa8e6f3fe8d85d6df12bf0f2574edc784977a20497df61734b",
"url": "https://osv.dev/vulnerability/CVE-2019-1000010",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-1000010",
"summary": "phpIPAM version 1.3.2 and earlier contains a Cross Site Scripting (XSS) vulnerability in subnet-scan-telnet.php that can result in executing code in victims browser. This attack appears to be exploitable via victim visits link crafted by an attacker. This vulnerability appears to have been fixed in 1.4.",
"evidence": "osv:CVE-2019-1000010",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2019-1000010",
"aliases": [
"CVE-2019-1000010"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/phpipam/phpipam",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "d22e50224ad89ec31c329576a25ba6ec64903857"
},
{
"fixed": "fd37bd8fb2b9c306079db505e0e3fe79a096c31c"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:phpipam:phpipam:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "1.3.2"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "fd37bd8fb2b9c306079db505e0e3fe79a096c31c"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.3.2",
"v1.3.0",
"v1.2.0_beta2",
"v1.19.008",
"v1.16.003"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-1000010.json"
}
}
],
"modified": "2026-10-20T10:50:34.129637687Z",
"provider": "osv",
"references": [
"https://github.com/phpipam/phpipam/issues/2327",
"https://github.com/phpipam/phpipam/commit/fd37bd8fb2b9c306079db505e0e3fe79a096c31c"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2019-1000010",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 381859,
"published_at": "2019-02-04T21:29:01.003+00:00"
}