UnratedFix available
rails — security advisory
Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
- Products
- rails
- Affected versions
- Not specified
- Fixed versions
- 2.3.14
- CVEs
- CVE-2012-1098
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 23:04 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
osv:DEBIAN-CVE-2012-1098
rails
Fixed versions: 2.3.14
rails
Fixed versions: 2.3.14
rails
Fixed versions: 2.3.14
Complete source record
{
"id": "07f56b6ec7d64b28a9ba43d074b519909a9be7cdf619ec0f80580606753208f3",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2012-1098",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2012-1098",
"summary": "Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.",
"evidence": "osv:DEBIAN-CVE-2012-1098",
"products": [
{
"name": {
"value": "rails",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.3.14",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "rails",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.3.14",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "rails",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.3.14",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2012-1098",
"aliases": [
"DEBIAN-CVE-2012-1098"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.14"
}
]
}
],
"package": {
"name": "rails",
"purl": "pkg:deb/debian/rails?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-1098.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.14"
}
]
}
],
"package": {
"name": "rails",
"purl": "pkg:deb/debian/rails?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-1098.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.14"
}
]
}
],
"package": {
"name": "rails",
"purl": "pkg:deb/debian/rails?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-1098.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:33.797512420Z",
"provider": "osv",
"upstream": [
"CVE-2012-1098"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2012-1098"
]
},
"related_cves": [
{
"value": "CVE-2012-1098",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 417638,
"published_at": "2012-03-13T10:55:01.213+00:00"
}