High
TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs
Type: advisorySources: OSV
TinyMCE is an open source rich text editor. From 6.8.0 to before 7.1.0, TinyMCE contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested elements can bypass attribute sanitization and execute arbitrary JavaScript. This vulnerability is fixed in 7.1.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-47760
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 06:02 UTC · Revision 1
Source evidence
TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs
core-osv · Original sourcePublished 28 May 2026, 15:18 UTC
TinyMCE is an open source rich text editor. From 6.8.0 to before 7.1.0, TinyMCE contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested elements can bypass attribute sanitization and execute arbitrary JavaScript. This vulnerability is fixed in 7.1.0.
osv:CVE-2026-47760
Complete source record
{
"id": "4d8754a88661c9f4f0b0515eee5678fae0a37cfb660659acc52e40bc48e197ee",
"url": "https://osv.dev/vulnerability/CVE-2026-47760",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs",
"summary": "TinyMCE is an open source rich text editor. From 6.8.0 to before 7.1.0, TinyMCE contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested elements can bypass attribute sanitization and execute arbitrary JavaScript. This vulnerability is fixed in 7.1.0.",
"evidence": "osv:CVE-2026-47760",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-47760",
"aliases": [
"CVE-2026-47760",
"GHSA-mh5m-5hw4-5c69"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/tinymce/tinymce",
"type": "GIT",
"events": [
{
"introduced": "4cc623897917472ba418f1378170727d7a94575b"
},
{
"fixed": "d1f9346bc98acb3cdfe700e6e6fd310f356ef2b8"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "6.0.0"
},
{
"fixed": "7.1.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "6.8.0"
},
{
"fixed": "7.1.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-47760.json"
}
}
],
"modified": "2026-10-28T02:30:43.179457017Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/47xxx/CVE-2026-47760.json",
"https://github.com/tinymce/tinymce/security/advisories/GHSA-mh5m-5hw4-5c69",
"https://nvd.nist.gov/vuln/detail/CVE-2026-47760"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/47xxx/CVE-2026-47760.json"
}
},
"related_cves": [
{
"value": "CVE-2026-47760",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 510928,
"published_at": "2026-05-28T15:18:22.509+00:00"
}