Stored XSS-LibreNMS-Display Name 2 in librenms
librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to a stored XSS on the parameters (Replace $DEVICE_ID with your specific $DEVICE_ID value):`/device/$DEVICE_ID/edit` -> param: display. Librenms versions up to 24.11.0 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.12.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-56144
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 02:10 UTC · Revision 1
Source evidence
Stored XSS-LibreNMS-Display Name 2 in librenms
core-osv · Original sourcePublished 16 Jan 2025, 22:28 UTC
librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to a stored XSS on the parameters (Replace $DEVICE_ID with your specific $DEVICE_ID value):`/device/$DEVICE_ID/edit` -> param: display. Librenms versions up to 24.11.0 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.12.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
osv:CVE-2024-56144
Complete source record
{
"id": "fa8f0bb5a8e1d07265273754f640269faf8d81bdced0275628d327cc45c93eb5",
"url": "https://osv.dev/vulnerability/CVE-2024-56144",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Stored XSS-LibreNMS-Display Name 2 in librenms",
"summary": "librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to a stored XSS on the parameters (Replace $DEVICE_ID with your specific $DEVICE_ID value):`/device/$DEVICE_ID/edit` -> param: display. Librenms versions up to 24.11.0 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.12.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.",
"evidence": "osv:CVE-2024-56144",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-56144",
"aliases": [
"CVE-2024-56144",
"GHSA-2f4w-6mc7-4w78"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/librenms/librenms",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "18a4b056ea3c160ee08ec7e3c46f1d2825a0e469"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "24.12.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "24.12.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"24.11.0",
"24.10.1",
"24.10.0",
"24.9.1",
"24.9.0",
"24.8.0",
"24.7.0",
"24.6.0",
"24.5.0",
"24.4.1",
"24.4.0",
"24.3.0",
"24.2.0",
"24.1.0",
"23.11.0",
"23.10.0",
"23.9.1",
"23.9.0",
"23.8.2",
"23.8.1",
"23.8.0",
"23.7.0",
"23.6.0",
"23.5.0",
"23.4.1",
"23.4.0",
"23.2.0",
"23.1.0",
"22.12.0",
"22.11.0",
"22.10.0",
"22.9.0",
"22.8.0",
"22.7.0",
"22.6.0",
"22.5.0",
"22.4.0",
"22.3.0",
"22.2.1",
"22.2.0",
"22.1.0",
"21.12.1",
"21.12.0",
"21.11.0",
"21.10.0",
"21.9.0",
"21.8.0",
"21.7.0",
"21.6.0",
"21.5.1",
"21.5.0",
"21.4.0",
"21.3.0",
"21.2.0",
"21.1.0",
"1.70.1",
"1.70.0",
"1.69",
"1.68",
"1.67",
"1.66",
"1.65",
"1.64.1",
"1.64",
"1.63",
"1.62",
"1.61",
"1.60",
"1.59",
"1.58.1",
"1.58",
"1.57",
"1.56",
"1.55",
"1.54",
"1.53.1",
"1.53",
"1.52",
"1.51",
"1.50",
"1.49",
"1.48.1",
"1.48",
"1.47",
"1.46",
"1.45",
"1.44",
"1.43",
"1.42.01",
"1.42",
"1.41",
"1.40",
"1.39",
"1.38",
"1.37",
"1.36",
"1.35",
"1.33",
"1.32",
"1.31.03",
"1.31.02",
"1.31.01",
"1.28",
"1.27",
"1.26",
"1.25",
"1.21",
"201609",
"1.20",
"20160828",
"1.19",
"201608",
"201607",
"201606",
"201605",
"201604",
"201603",
"201602",
"201601",
"201512",
"201511",
"201510",
"201509",
"201508",
"201507",
"201505",
"201506",
"0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-56144.json"
}
}
],
"modified": "2026-10-28T02:30:45.907865495Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/56xxx/CVE-2024-56144.json",
"https://github.com/librenms/librenms/security/advisories/GHSA-2f4w-6mc7-4w78",
"https://nvd.nist.gov/vuln/detail/CVE-2024-56144"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/56xxx/CVE-2024-56144.json"
}
},
"related_cves": [
{
"value": "CVE-2024-56144",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 514160,
"published_at": "2025-01-16T22:28:03.567+00:00"
}