UnratedFix available
mediawiki — security advisory
Cross-site scripting (XSS) vulnerability in the API pretty-printing mode in MediaWiki 1.8.0 through 1.8.4, 1.9.0 through 1.9.3, 1.10.0 through 1.10.1, and the 1.11 development versions before 1.11.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Products
- mediawiki
- Affected versions
- Not specified
- Fixed versions
- 1.10.2-1
- CVEs
- CVE-2007-4828
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 15:46 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in the API pretty-printing mode in MediaWiki 1.8.0 through 1.8.4, 1.9.0 through 1.9.3, 1.10.0 through 1.10.1, and the 1.11 development versions before 1.11.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
osv:DEBIAN-CVE-2007-4828
mediawiki
Fixed versions: 1.10.2-1
mediawiki
Fixed versions: 1.10.2-1
mediawiki
Fixed versions: 1.10.2-1
Complete source record
{
"id": "5142c125ff9e687b5cb2878bbe0019448dea53bb4f15bb02cac83ca0502d29d2",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2007-4828",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2007-4828",
"summary": "Cross-site scripting (XSS) vulnerability in the API pretty-printing mode in MediaWiki 1.8.0 through 1.8.4, 1.9.0 through 1.9.3, 1.10.0 through 1.10.1, and the 1.11 development versions before 1.11.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.",
"evidence": "osv:DEBIAN-CVE-2007-4828",
"products": [
{
"name": {
"value": "mediawiki",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.10.2-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mediawiki",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.10.2-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mediawiki",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.10.2-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2007-4828",
"aliases": [
"DEBIAN-CVE-2007-4828"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.10.2-1"
}
]
}
],
"package": {
"name": "mediawiki",
"purl": "pkg:deb/debian/mediawiki?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-4828.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.10.2-1"
}
]
}
],
"package": {
"name": "mediawiki",
"purl": "pkg:deb/debian/mediawiki?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-4828.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.10.2-1"
}
]
}
],
"package": {
"name": "mediawiki",
"purl": "pkg:deb/debian/mediawiki?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-4828.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-21T17:47:37.717292325Z",
"provider": "osv",
"upstream": [
"CVE-2007-4828"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2007-4828"
]
},
"related_cves": [
{
"value": "CVE-2007-4828",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 398381,
"published_at": "2007-09-12T19:17:00+00:00"
}