Critical
trafficserver — security advisory
Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 9.2.0 through 9.2.14, from 10.1.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fixes the issue.
- Products
- trafficserver
- Affected versions
- 9.2.0+ds-2, 9.2.0+ds-2+deb12u1, 9.2.1+ds-1, 9.2.2+ds-1, 9.2.3+ds-1, 9.2.3+ds-1+deb12u1, 9.2.4+ds-0+deb12u1, 9.2.4+ds-1, 9.2.4+ds-2, 9.2.5+ds-0+deb12u1, 9.2.5+ds-0+deb12u2, 9.2.5+ds-0+deb12u3, 9.2.5+ds-0+deb12u4, 9.2.5+ds-1
- Fixed versions
- Not specified
- CVEs
- CVE-2026-33267
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:07 UTC · Revision 1
Source evidence
Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 9.2.0 through 9.2.14, from 10.1.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fixes the issue.
osv:DEBIAN-CVE-2026-33267
trafficserver
Fixed versions: Not specified
Complete source record
{
"id": "87ddd078766e4c3a464115c53d026c76a4528d6761e5f51fe9022e7c4ec77f1d",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-33267",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-33267",
"summary": "Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 9.2.0 through 9.2.14, from 10.1.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fixes the issue.",
"evidence": "osv:DEBIAN-CVE-2026-33267",
"products": [
{
"name": {
"value": "trafficserver",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "9.2.0+ds-2",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.0+ds-2+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.1+ds-1",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.2+ds-1",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.3+ds-1",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.3+ds-1+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.4+ds-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.4+ds-1",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.4+ds-2",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.5+ds-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.5+ds-0+deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.5+ds-0+deb12u3",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.5+ds-0+deb12u4",
"evidence": "/affected/0/versions"
},
{
"value": "9.2.5+ds-1",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2026-33267",
"aliases": [
"DEBIAN-CVE-2026-33267"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "trafficserver",
"purl": "pkg:deb/debian/trafficserver?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"9.2.0+ds-2",
"9.2.0+ds-2+deb12u1",
"9.2.1+ds-1",
"9.2.2+ds-1",
"9.2.3+ds-1",
"9.2.3+ds-1+deb12u1",
"9.2.4+ds-0+deb12u1",
"9.2.4+ds-1",
"9.2.4+ds-2",
"9.2.5+ds-0+deb12u1",
"9.2.5+ds-0+deb12u2",
"9.2.5+ds-0+deb12u3",
"9.2.5+ds-0+deb12u4",
"9.2.5+ds-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-33267.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-24T09:47:30.543094507Z",
"provider": "osv",
"upstream": [
"CVE-2026-33267"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-33267"
]
},
"related_cves": [
{
"value": "CVE-2026-33267",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 428994,
"published_at": "2026-07-29T08:16:30.983+00:00"
}