bouncycastle — security advisory
Bouncy Castle For Java before 1.74 is affected by an LDAP injection vulnerability. The vulnerability only affects applications that use an LDAP CertStore from Bouncy Castle to validate X.509 certificates. During the certificate validation process, Bouncy Castle inserts the certificate's Subject Name into an LDAP search filter without any escaping, which leads to an LDAP injection vulnerability.
- Products
- bouncycastle
- Affected versions
- 1.72-2, 1.77-1, 1.80-1, 1.80-2, 1.80-3, 1.86-1
- Fixed versions
- 1.77-1
- CVEs
- CVE-2023-33201
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 16:05 UTC · Revision 1
Source evidence
Bouncy Castle For Java before 1.74 is affected by an LDAP injection vulnerability. The vulnerability only affects applications that use an LDAP CertStore from Bouncy Castle to validate X.509 certificates. During the certificate validation process, Bouncy Castle inserts the certificate's Subject Name into an LDAP search filter without any escaping, which leads to an LDAP injection vulnerability.
osv:DEBIAN-CVE-2023-33201
bouncycastle
Fixed versions: Not specified
bouncycastle
Fixed versions: 1.77-1
bouncycastle
Fixed versions: 1.77-1
Complete source record
{
"id": "39edfc78bf964c6fd1a8b0e14ba2af2fa69ec9eaaedffecccecea78e240b9b41",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-33201",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-33201",
"summary": "Bouncy Castle For Java before 1.74 is affected by an LDAP injection vulnerability. The vulnerability only affects applications that use an LDAP CertStore from Bouncy Castle to validate X.509 certificates. During the certificate validation process, Bouncy Castle inserts the certificate's Subject Name into an LDAP search filter without any escaping, which leads to an LDAP injection vulnerability.",
"evidence": "osv:DEBIAN-CVE-2023-33201",
"products": [
{
"name": {
"value": "bouncycastle",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.72-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.77-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.80-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.80-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.80-3",
"evidence": "/affected/0/versions"
},
{
"value": "1.86-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "bouncycastle",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.77-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "bouncycastle",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.77-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2023-33201",
"aliases": [
"DEBIAN-CVE-2023-33201"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "bouncycastle",
"purl": "pkg:deb/debian/bouncycastle?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.72-2",
"1.77-1",
"1.80-1",
"1.80-2",
"1.80-3",
"1.86-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-33201.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.77-1"
}
]
}
],
"package": {
"name": "bouncycastle",
"purl": "pkg:deb/debian/bouncycastle?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-33201.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.77-1"
}
]
}
],
"package": {
"name": "bouncycastle",
"purl": "pkg:deb/debian/bouncycastle?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-33201.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:40.931683543Z",
"provider": "osv",
"upstream": [
"CVE-2023-33201"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-33201"
]
},
"related_cves": [
{
"value": "CVE-2023-33201",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456582,
"published_at": "2023-07-05T03:15:09.197+00:00"
}