Low
Directorist < 7.5.4 - Admin+ LFI
Type: advisorySources: OSV
The Directorist WordPress plugin before 7.5.4 is vulnerable to Local File Inclusion as it does not validate the file parameter when importing CSV files.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-2252
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 08:57 UTC · Revision 1
Source evidence
The Directorist WordPress plugin before 7.5.4 is vulnerable to Local File Inclusion as it does not validate the file parameter when importing CSV files.
osv:CVE-2023-2252
Complete source record
{
"id": "4d99eec25e46ae0f26bf1d641970e21c5e51bc936e98facdc921e27ab60655cd",
"url": "https://osv.dev/vulnerability/CVE-2023-2252",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Directorist < 7.5.4 - Admin+ LFI",
"summary": "The Directorist WordPress plugin before 7.5.4 is vulnerable to Local File Inclusion as it does not validate the file parameter when importing CSV files.",
"evidence": "osv:CVE-2023-2252",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2023-2252",
"aliases": [
"CVE-2023-2252"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/sovware/directorist",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d659b9a317cc64a744e5531703a2c45cb907916f"
}
],
"database_specific": {
"cpe": "cpe:2.3:a:wpwax:directorist:*:*:*:*:*:wordpress:*:*",
"source": "CPE_RANGE",
"extracted_events": [
{
"introduced": "0"
},
{
"fixed": "7.5.4"
}
]
}
}
],
"versions": [
"v7.5.3",
"v7.5.1",
"v7.4.6",
"v7.4.5",
"v7.4.3",
"v7.4.2",
"v7.4.1",
"v7.4.0",
"v7.3.3",
"v7.3.2",
"v7.3.1.2",
"v7.3.1",
"v7.3.0",
"v7.2.2",
"v7.2.1",
"v7.2.0",
"v7.1.2",
"v7.1.1",
"v7.1.0",
"v7.0.8",
"v7.0.7",
"v7.0.6.3",
"v7.0.6.2",
"v7.0.6.1",
"v7.0.6",
"v7.0.5.6",
"v7.0.5.4",
"v7.0.5.3",
"v7.0.5.2",
"v7.0.5.1",
"v7.0.5",
"v7.0.4.1",
"released-v7.0.4",
"v7.0.3.3",
"v7.0.3.2",
"v7.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-2252.json"
}
}
],
"modified": "2026-10-08T02:48:08.456404833Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/2xxx/CVE-2023-2252.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-2252",
"https://wpscan.com/vulnerability/9da6eede-10d0-4609-8b97-4a5d38fa8e69/"
],
"provider_metadata": {
"cna_assigner": "WPScan",
"unresolved_ranges": [
{
"source": "AFFECTED_FIELD",
"extracted_events": [
{
"fixed": "7.5.4"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/2xxx/CVE-2023-2252.json"
}
},
"related_cves": [
{
"value": "CVE-2023-2252",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 98268,
"published_at": "2024-01-16T15:55:41.055+00:00"
}