Skip to content
Heist/ feed
Back to feed
UnratedFix available

phpmyadmin — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2012-1902

show_config_errors.php in phpMyAdmin 3.4.x before 3.4.10.2, when a configuration file does not exist, allows remote attackers to obtain sensitive information via a direct request, which reveals the installation path in an error message about this missing file.

Products
phpmyadmin
Affected versions
Not specified
Fixed versions
4:3.4.10.2-1
CVEs
CVE-2012-1902
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 23:13 UTC · Revision 1

Source evidence

DEBIAN-CVE-2012-1902

core-osv · Original source

Published 6 Apr 2012, 19:55 UTC

show_config_errors.php in phpMyAdmin 3.4.x before 3.4.10.2, when a configuration file does not exist, allows remote attackers to obtain sensitive information via a direct request, which reveals the installation path in an error message about this missing file.

osv:DEBIAN-CVE-2012-1902

phpmyadmin

Fixed versions: 4:3.4.10.2-1

phpmyadmin

Fixed versions: 4:3.4.10.2-1

phpmyadmin

Fixed versions: 4:3.4.10.2-1

Complete source record
{
  "id": "cad65793025494678f742ac6d515dc47691a46dd17345946b987e860372a696c",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2012-1902",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2012-1902",
    "summary": "show_config_errors.php in phpMyAdmin 3.4.x before 3.4.10.2, when a configuration file does not exist, allows remote attackers to obtain sensitive information via a direct request, which reveals the installation path in an error message about this missing file.",
    "evidence": "osv:DEBIAN-CVE-2012-1902",
    "products": [
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:3.4.10.2-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:3.4.10.2-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:3.4.10.2-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2012-1902",
      "aliases": [
        "DEBIAN-CVE-2012-1902"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:3.4.10.2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-1902.json"
          },
          "ecosystem_specific": {
            "urgency": "unimportant"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:3.4.10.2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-1902.json"
          },
          "ecosystem_specific": {
            "urgency": "unimportant"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:3.4.10.2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-1902.json"
          },
          "ecosystem_specific": {
            "urgency": "unimportant"
          }
        }
      ],
      "modified": "2026-10-23T17:47:37.731330300Z",
      "provider": "osv",
      "upstream": [
        "CVE-2012-1902"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2012-1902"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2012-1902",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 418021,
  "published_at": "2012-04-06T19:55:01.717+00:00"
}