CriticalFix available
ansible — security advisory
The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.
- Products
- ansible
- Affected versions
- Not specified
- Fixed versions
- 1.6.6+dfsg-1
- CVEs
- CVE-2014-4678
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:52 UTC · Revision 1
Source evidence
The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.
osv:DEBIAN-CVE-2014-4678
ansible
Fixed versions: 1.6.6+dfsg-1
ansible
Fixed versions: 1.6.6+dfsg-1
ansible
Fixed versions: 1.6.6+dfsg-1
Complete source record
{
"id": "5bac28bf92161f67ca37117c415158ad646896aea58460b023780f428cfc552d",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-4678",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-4678",
"summary": "The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.",
"evidence": "osv:DEBIAN-CVE-2014-4678",
"products": [
{
"name": {
"value": "ansible",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.6+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ansible",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.6+dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ansible",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.6+dfsg-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2014-4678",
"aliases": [
"DEBIAN-CVE-2014-4678"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.6+dfsg-1"
}
]
}
],
"package": {
"name": "ansible",
"purl": "pkg:deb/debian/ansible?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4678.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.6+dfsg-1"
}
]
}
],
"package": {
"name": "ansible",
"purl": "pkg:deb/debian/ansible?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4678.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.6+dfsg-1"
}
]
}
],
"package": {
"name": "ansible",
"purl": "pkg:deb/debian/ansible?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4678.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T16:01:50.902661666Z",
"provider": "osv",
"upstream": [
"CVE-2014-4678"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-4678"
]
},
"related_cves": [
{
"value": "CVE-2014-4678",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 414777,
"published_at": "2020-02-20T03:15:10.717+00:00"
}