Skip to content
Heist/ feed
Back to feed
CriticalFix available

ruby-faye — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2020-11020

Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.

Products
ruby-faye
Affected versions
Not specified
Fixed versions
1.4.0-1
CVEs
CVE-2020-11020
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 12:55 UTC · Revision 1

Source evidence

DEBIAN-CVE-2020-11020

core-osv · Original source

Published 29 Apr 2020, 18:15 UTC

Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.

osv:DEBIAN-CVE-2020-11020

ruby-faye

Fixed versions: 1.4.0-1

Complete source record
{
  "id": "04640ccda25b627b49148fa9e4cd88d457161e794d008936aa1a127c40b8881d",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2020-11020",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2020-11020",
    "summary": "Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.",
    "evidence": "osv:DEBIAN-CVE-2020-11020",
    "products": [
      {
        "name": {
          "value": "ruby-faye",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.4.0-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "DEBIAN-CVE-2020-11020",
      "aliases": [
        "DEBIAN-CVE-2020-11020"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.4.0-1"
                }
              ]
            }
          ],
          "package": {
            "name": "ruby-faye",
            "purl": "pkg:deb/debian/ruby-faye?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-11020.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-26T12:01:17.651408495Z",
      "provider": "osv",
      "upstream": [
        "CVE-2020-11020"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2020-11020"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2020-11020",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 451550,
  "published_at": "2020-04-29T18:15:13.36+00:00"
}