Medium
Security advisory
Jenkins Job Import Plugin 3.5 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-43413
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:48 UTC · Revision 1
Source evidence
Jenkins Job Import Plugin 3.5 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.
osv:CVE-2022-43413
Complete source record
{
"id": "4c3b0f7629b17ff860837c154d16f7888c5da0f9e0ec67c523ed49b104dfc2a3",
"url": "https://osv.dev/vulnerability/CVE-2022-43413",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2022-43413",
"summary": "Jenkins Job Import Plugin 3.5 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.",
"evidence": "osv:CVE-2022-43413",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-43413",
"aliases": [
"CVE-2022-43413",
"GHSA-4g29-r7vj-2rpv"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jenkinsci/job-import-plugin",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "85ccf218080d99aad861e766e0c7a2e421025735"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:jenkins:job_import:*:*:*:*:*:jenkins:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.6"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"job-import-plugin-3.5",
"job-import-plugin-3.4",
"job-import-plugin-3.3",
"job-import-plugin-3.2",
"job-import-plugin-3.1",
"job-import-plugin-3.0",
"job-import-plugin-2.1",
"job-import-plugin-2.0",
"job-import-plugin-1.8",
"job-import-plugin-1.7",
"job-import-plugin-1.6",
"job-import-plugin-1.4",
"job-import-plugin-1.3.1",
"job-import-plugin-1.3",
"job-import-plugin-1.2",
"job-import-plugin-1.1",
"job-import-plugin-1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-43413.json"
}
}
],
"modified": "2026-10-24T10:30:44.743284573Z",
"provider": "osv",
"references": [
"https://www.jenkins.io/security/advisory/2022-10-19/#SECURITY-2791"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2022-43413",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 435954,
"published_at": "2022-10-19T16:15:10.83+00:00"
}